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Dostek Model 440A
Behind-the-Tape Reader (BTR)

Software Guide
This Guide explains how to use the Dostek DNC Lite Edition software included free with
purchase of the Dostek Model 440A Behind-the-Tape Reader (BTR).

In this guide, you will learn about: 

177. Technical Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

156. Troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

145. Data Backup - Planning for Disaster . . . . . . . . . . . . . . . . . . .

94. Using Dostek DNC . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

83. Configuring Dostek DNC . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

52. Software Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

21. Software Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

Documentation

The following additional documentation is available:

PDF manual. Online copies of the full Dostek DNC User Guide and Dostek DNC
Configuration Guide are installed on your computer along with the Dostek DNC
software. To view the manuals, start the Dostek DNC Navigator application (page 5)
and select the "Documents" tab.

Application notes. Application notes covering a variety of topics are installed on your
computer as PDF files. To view the application notes, start the Dostek DNC Navigator
application, select the "Application Notes" tab, and then click Application note
selector.

Online help. Several online help files are included with the Dostek DNC software. To
view help files, look in the Help menu in the Dostek DNC applications, or select the
"Help" tab in Dostek DNC Navigator. Available files include:

Dostek DNC Com Test Terminal
(see the topic "Using BTR Test Features")

DTerminal.chm

Dostek DNC ConfigurationDConfig.chm

Communication Testing and TroubleshootingComTest.chm

Getting Started guide.GettingStarted.chm

Master help. All help files combined into a single file.DostekDNC.chm
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1 Installing Dostek DNC

This section explains how to install the Dostek DNC software.

If you are installing Dostek DNC for the first time, go to Section 1.1, "Installing Dostek
DNC."

If you are updating an existing copy of the Dostek DNC software:

• If the current software is working properly, see "Updating Dostek DNC" below.

• If the current software is not working properly, see "Replacing Dostek DNC" below.

Updating Dostek DNC

To update an existing, working, copy of the Dostek DNC software:

1. Make a backup copy of your computer's "C:\Dostek DNC\Settings" folder. This
folder contains your current Dostek DNC software configuration options.

2. Go to Section 1.1, "Installing Dostek DNC."

Replacing Dostek DNC

To replace (erase and reinstall) an existing copy of the Dostek DNC software:

1. Make a backup copy of your computer's "C:\Dostek DNC\Settings" folder. This
folder contains your current Dostek DNC software configuration options.

2. Uninstall Dostek DNC using "Programs" or "Install/Remove Programs" in the
Windows Control Panel.

3. Erase your computer's "C:\Dostek DNC" folder.

4. Go to Section 1.1, "Installing Dostek DNC."

1.1 Installing Dostek DNC

To install Dostek DNC:

1. Insert the Dostek DNC software CD in your computer's CD or DVD drive. Setup
starts automatically within a few seconds. 
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2. Follow the on-screen instructions to complete the installation. When finished,
Setup automatically starts the Dostek DNC First-Time Setup wizard.

First-Time Setup Wizard guides you through:

¤ Restoring a previous Dostek DNC configuration.

¤ Installing your software license key. 

¤ Viewing the Getting Started Guide. 

¤ Setting up file locations and program shortcuts. 

¤ Selecting from the supplied sample CNC configurations. 

¤ Learning about backing up your data. 

3. When the wizard prompts you to "Choose setup mode,", choose one of the
following options:

¤ If you are installing Dostek DNC for the first time, select New Installation
and continue following the wizard's on-screen instructions.

¤ If you are updating an existing, working, copy of the software, select Keep
existing configuration, or simply click Cancel.

¤ If you are replacing a previous copy of the software, and you have saved a
copy of your previous configuration settings, select Load previously-saved
configuration, and follow the wizard's on-screen instructions to restore your
previous settings.

When finished, First-Time Setup Wizard automatically starts the Dostek DNC Navigator
application.

Notes:

› If Setup does not start automatically, browse the CD and open "Setup.exe".

› The Dostek DNC software CD is shipped in a plastic pouch fixed inside the front
cover of the manual.

Dostek 440A BTR Software Guide Page 3 



 Page 4 Dostek 440A BTR Software Guide 

Dostek DNC Navigator (DDNav.exe)

Dostek DNC File Manager (DFileMgr.exe)



2 Software Overview

Dostek DNC is a suite of applications that work together to provide file management,
editing and DNC communication. 

With Dostek DNC, you can: 

• Transfer programs and data between the computer and CNC machine tools. 

• Upload, download, and drip feed with data transfer rates up to 38,400 baud. 

• Edit files, including: copy and paste, search and replace, reformat and renumber. 

• Manage files, including: view, search, copy, rename, filter, and delete. 

• Configure communication parameters and protocols to work with virtually any CNC
machine. 

• Configure security and logging to control access and track activity. 

• Work with standard Windows PCs (Windows XP through Windows 7). 

• Work with multi-port serial cards and hubs (Ethernet and USB, wired and
wireless).

The following paragraphs provide an overview of the main software components.

Navigator - DDNAV

Dostek DNC Navigator provides links to Dostek DNC applications, documents, help
files, and more. Links are categorized by tabs so you can quickly find what you need. 

To start Navigator, click Start, All Programs, Dostek DNC, Dostek DNC
Navigator. You can also start Navigator from the Help menu in another Dostek DNC
application.

To guide new users, Navigator starts automatically each time Windows starts. You can
clear this option when you become familiar with the software.

File Manager - DFileMgr

Dostek DNC File Manager has the familiar look and feel of classic Windows Explorer,
but is easier to use and provides many enhancements and security features. With File
Manager, you can:

• Organize your files however you like. You decide which folders to view. You can
include folders on the computer's hard drive, a network drive or a removable
media.

• Browse folders and select files. 

• View, print, copy, rename and delete files. 

• Customize "QuickButton" command buttons and Utilities menu. 

• Limit access to specific folders and file types. 

• Require a password to modify files.

To start Dostek DNC File Manager, you can:

• Click the Windows Start button, point to All Programs, Dostek DNC, and then
click Dostek DNC File Manager.

• Click the File Manager shortcut on the Windows Desktop or Quick Launch toolbar.
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Communication - DDNC

Dostek DNC Communication transfers files between the computer and CNC machine
tools. With Dostek DNC Communication, you can: 

• Load, save and drip feed with transfer rates up to 38,400 baud. 

• Stop, start, repeat, or restart anywhere in the file when drip-feeding. 

• Automatically store received programs according to the program name or part
number. 

• Automatically select a machine configuration according to the current file folder. 

• Display customized on-screen operator instructions. 

Editor - DEditor

Dostek DNC Editor is a multiple-document editor for CNC part programs and text files.
With Dostek DNC Editor, you can: 

• Open multiple files of virtually unlimited size. 

• Copy text between files. 

• Search and replace text. 

• Undo and redo changes. 

• Reformat CNC part programs (expand, compress, resequence and reformat
numbers).

Configuration  - DConfig

Dostek DNC Configuration lets you quickly configure software options and communica-
tion parameters. With Dostek DNC configuration, you can: 

• Configure general settings including file locations, security settings and global
options. 

• Configure CNC communication settings including baud rate, parity and flow control
options. 

• Choose from sample configurations for most CNC models. 

• Create a separate configuration for each CNC. 

• View a detailed help page, with practical examples, for each configuration
category. 

• Record notes for each configuration. 

• Use the New Device Setup Wizard to guide you through CNC communication
configuration options.

• Use the Configuration Manager Wizard to quickly back up and restore configuration
information.

Tools and Utilities

For more information about Dostek DNC's tools and utilities, open Navigator and click
Getting Started Guide.      
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3 Configuring Dostek DNC

After you complete the Dostek DNC First-Time Setup Wizard, the software is ready to
use. However, Dostek DNC offers many options that let you configure the software to
suit your needs and preferences.

Configuring General and Communication Settings

To use the Dostek DNC Configuration application (DConfig) to change general settings
and CNC communication settings:

1. Start the Dostek DNC File Manager.

2. Do one of the following:

¤ To change general settings such as file locations and security settings, click
Configure Dostek DNC in the Supervisor menu.

¤ To change CNC settings such as baud rate, flow control and data format, click
Configure devices (CNCs) in the Supervisor menu.

Settings are organized by "tabs" to make it easy to find the setting you need. Detailed
help is provided. To learn about settings found on a particular tab, click Help in the
Help menu.

Notes:

› Sample device configuration files are provided for a variety of CNCs. To use a
sample configuration, click Import sample configuration in DConfig's File
menu.

› You can also start the Dostek DNC Configuration application from the
Configuration tab in Dostek DNC Navigator, and from the Windows Start menu.

Configuring File Manager

To change File Manager options:

• Click Options in the Supervisor menu, and then do one of the following:

¤ Select the View Preferences tab to change display preferences.

¤ Select the File Type Filters tab to change the types of files that are
displayed.

¤ Select the QuickButtons tab to add or change QuickButtons.

¤ Select the Utilities tab to add or change commands on the Utilities menu.

Configuring Editor

To change the Editor font, which is also used for printing and viewing, click Prefer-
ences in the Editor's File menu.

To change the page layout and font size used for printing, click Page Setup in the
Editor's File menu.
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4 Using Dostek DNC

Before you get started, here are a few things you should know about Dostek DNC:

Multi-Tasking. Dostek DNC's modular design means you can simultaneously open
multiple windows. For example, you can have the File Manager, Editor and Communi-
cation windows all open at the same time. Switch between windows by clicking in the
Windows taskbar or by pressing Alt+Tab.

Single Instance. You can only open one copy (instance) of most applications. If you
try to open a new copy of an application that is already open, the existing window
automatically pops to the top. Although you can only open one Editor window, you can
open multiple files within the editor.

Tooltips. You can get a hint about the purpose of most of the software features
(toolbar and command buttons, lists and text boxes, and so on) by hovering the
mouse over them. 

4.1 Sending a File to the CNC

Sending a file to the CNC is a simple 3-step process with Dostek DNC:

STEP 1 - Start Dostek DNC File Manager.

With File Manager, folders are shown in the left window, and files in the right
window.

   

Dostek 440A BTR Software Guide Page 9 



STEP 2 - Select a file and click 'Send'.

In File Manager, find the file you want to send, select it, and then click Send. File
Manager launches the Communication application (DDNC) to send the file to the
CNC. 

If you created more than one CNC configuration file, the DDNC "Settings" window
appears automatically to let you pick a configuration.

When you are using a Dostek 440A BTR, DDNC immediately starts sending data to
the BTR. Progress of the transfer is displayed in the status panel at the bottom of
the window.

If your computer is connected directly to the CNC's RS-232C serial port (you are
not using a Dostek 440A BTR), DDNC pauses and indicates "Waiting for trigger" in
the status panel at the bottom of the window. 

STEP 3 - Go to the CNC, and start a Load or Run transfer.

Execute a read, load or run command on the CNC. You don't need to wait for the
entire file to load into the BTR memory.

4.2 Receiving a File from the CNC

Receiving a part program file from the CNC is also easy:

1. In Dostek DNC File Manager, select the folder you want to store the file into, and
then click Receive. File Manager opens the Communication application (DDNC) to
handle the transfer.

2. Go to the CNC, and start a punch transfer. The received data scrolls in the DDNC
window. 

Note:

› To receive a file from the CNC, the CNC's puncher output must be connected to
the computer, either directly to a COM port or indirectly via a Dostek 440A BTR. 
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4.3 Managing Files

This section explains how you can use Dostek DNC to:

• Select files and folders
• Manage root folders
• Create, renaming and deleting files and folders
• Copy and move files and folders
• Find a file
• View and print files
• Edit and reformat files
• Refresh the file display
• Compare files and use advanced searching

4.3.1 Selecting Files and Folders

To use or modify a file or folder, you must first select it:

• To select a single file, click the file.
• To select more than one consecutive file, press and hold the Shift key while

clicking files.
• To select more than one non-consecutive file, press and hold the Ctrl key while

clicking files.
• To select all files, click Select all files in the Edit menu.
• To clear file selections, click Clear selections in the Edit menu.

4.3.2 Managing Root Folders

To select the folders File Manager displays in it's folder window:

1. On the File menu, click Manage root folders. The "Manage Root Folders"
window opens, showing a list of all "root" folders currently displayed in File
Manager.

2. Do one of the following:

¤ Click My Computer to provide access to the root folder of all local and
network drives.

¤ Click Add to add another folder to the list.

¤ Click Remove to remove a folder from the list.

¤ Click Change to replace a folder in the list with a different folder.

¤ To rearrange the order of root folders, select a folder and then click the Up or
Down "Move" button

Note:

› You can also open the "Manage Root Folders" window by clicking it's icon in File
Manager's toolbar. 
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4.3.3 Creating, Renaming and Deleting Files and Folders

To rename or delete an existing file or folder, select the file and click Delete file or
Rename file in the File menu.     

To create a new file or folder:

1. In the folder window, select a folder in which to create the new file or folder.

2. In the File menu, point to Create new and then do one of the following:

¤ Click New file to create a new file.

¤ Click New folder to create a new folder.

¤ Click New duplicate file to create a duplicate copy of the currently-selected
file.

3. Type a name for the new file or folder, and then click OK. The new file or folder is
created in the file (right-hand) window.

Note:

› New duplicate file is available only when one file is selected.

4.3.4 Copying and Moving Files and Folders

Use standard Windows methods for copying and moving files and folders:

• Copy and paste

• Cut and paste (delete original file or folder after copying)

• Drag and drop

When you drag and drop files or folders, File Manager displays a menu when you
release the mouse button. This prevents you from accidentally moving files.

• Click Copy to add a copy of the items to the new location.

• Click Move to move the files from the previous location to the new location.

• Click Cancel if you change your mind.

Note:

› File Manager displays a warning before replacing an existing file or folder.  
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4.3.5 Finding a File

To find a file in the current folder:

1. On the File menu, choose Go to file. The "Go to file" window opens.

2. Type a file name. As you type, File Manager shows the name of the file that most
closely matches what you have typed so far. 

3. When the name of the file you are looking for appears, do one of the following:

¤ Click Send to send the file to the CNC.

¤ Click Edit to open the file in the Editor.

¤ Click View to view the file.

¤ Click Select to select the file and close the "Go to file" window.

¤ Click Cancel to close the dialog box.

Note:

› You can also open the "Go to file" using the following methods:

¤ Click the Go to file icon in File Manager's toolbar.

¤ Click File Manager's Go to file QuickButton.

¤ Press Ctrl+G.    
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4.3.6 Viewing and Printing Files

To view or print a file, select it and then click View or Print in the File menu.

Printing Files

To change printing options such as headers, margins, font size and page layout, click
Page setup in the Editor's File menu.

The Editor's font preference is used for printing. To change the setting, click Prefer-
ences in the Editor's File menu.

Note: 

› You can also print a file by opening it in the Editor and clicking Print in the
Editor's File menu.

Viewing Files

While viewing a file, you can:

• Click Print in the File menu to print the file.
• Click Edit in the File menu to open the file in the Editor.
• Click Send to CNC in the File menu to send the file directly to the CNC.
• Click Find in the Search menu to search for text.
• Press F3 to search again for the same text.
• Press F5 and F6 to quickly view the previous or next file.

4.3.1 Editing and Reformatting Part Programs

To edit a file, select it and then click Edit in the File menu.

With the Editor, you can:

• Open more than one file.
• Copy and paste or cut and paste text between open files.
• Search and replace text.
• Click Save as in the File menu to save the file with a different name
• Click Block numbers in the Tools menu to sequence or resequence part program

files
• Click Convert numeric values in the Tools menu to reformat numeric values
• Click Reformat in the Tools menu to reformat part programs by any of:

¤ Adding or removing spaces between words.
¤ Converting letters to upper case.
¤ Trimming leading and trailing spaces.
¤ Filtering (removing) non-standard characters

4.3.2 Refreshing the File List

Other Windows applications can create and modify files in the folders File Manager is
displaying. File Manager does not track these changes, so new files don't appear until
the next time you open the folder. To manually update the display, click Refresh in
the View menu, or click the Refresh icon in the toolbar.

4.3.3 Comparing Files and Advanced Searching

Side-by-side file comparison lets you compare two versions of a file to find differences
or track changes.

Advanced searching lets you search files and folders to find text. For example, you can
see a list of all files containing a particular part number. 

These features are available with a Dostek DNC Professional Edition software upgrade.
Contact Dostek for more information.    
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5 Data Backup - Planning for Disaster

To protect your investment against computer failure or loss of data, take the following
basic precautions: 

• Make a duplicate copy of your Dostek DNC software CD. For example:

¤ Copy the CD to another CD.

¤ Copy the CD content to a shared folder on your network file server.

• Make regular backup copies of your CNC data files.

• Make a backup copy of your Dostek DNC configuration files after initial installation
and then any time you change configuration settings.

• Store your manual and software CD in a secure location so you can find the CD
when you need to reinstall the software.

Note:

› To make a backup copy of your Dostek DNC configuration files, click Express
Backup in the Tools menu in the Dostek DNC Configuration application.

In addition to these basic precautions, consider the following additional ways to
protect your investment.

Make multiple backup copies. Two copies is better than one. Store your backup
copies in secure locations where you can find them when you need them.

Make an off-site backup copy. Store at least one copy of your data off-site. You
can:

¤ Copy your data to CDs, DVDs or a portable drive.

¤ Copy your files to Web-based storage, such as SkyDrive (Microsoft) or Google
Docs.

¤ Subscribe to an automatic off-site backup service like Carbonite Online
Backup.

Prepare a written disaster recovery plan. Make a detailed recovery plan. Write
down how and where your data is backed up. Test your procedure, and review it at
least annually.

Set up a backup computer. Install your software and data on a second computer
so you can quickly replace your main computer when it fails. Update the data files
and test the computer every few months.

Add Dostek DNC to your regular backup. If you have an in-house data backup
system, consider adding Dostek DNC's "Settings" folder to the backup.

Write down your CNC's communication parameters. Write them down in the
CNC's manual, or in the "Notes" tab in the Dostek DNC Configuration application.

Save your CNC parameters. Most CNC's let you output all of the parameters to a
computer. Use Dostek DNC to save the data in a disk file. Include the date in the
file name so you know when the parameters were saved. If your CNC ever loses it's
parameter memory, you can load the data from the computer instead of typing it
all in by hand.
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6 Troubleshooting 

This section helps you with:

• Resolving installation problems (Section 7.1)
• Resolving software problems (Section 7.2)
• Resolving CNC communication problems (Section 7.3)

For more information about troubleshooting procedures, download the Technical
Support Procedures document from the Support page on the Dostek Web site.

6.1 Resolving Installation Problems

If you encounter a problem while installing the Dostek DNC software:

• Write down, print or save a screen image of every error message.

• To install the software, log on to your computer using an account with administra-
tor privileges.

• Ensure that all other Windows applications are closed before starting the installa-
tion. 

• Carefully read and follow all messages and instructions displayed on your
computer screen during installation. 

• Fully complete the Dostek DNC First-Time Setup Wizard. It starts automatically
when the software installation is completed. 

• Try installing Dostek DNC on a different computer. There may be a problem with
your computer. Windows computers can become unstable over time due to
viruses, spyware, registry corruption, installation of non-compliant applications,
and so on.  

6.2 Resolving Software Problems

If you encounter a problem when you start the Dostek DNC software or perform a
specific task:

• Write down, print or save a screen image of every error message.

• Write down exactly what you were attempting to do when the problem occurred,
including the commands or key sequences you pressed.

• Restart the computer and try again. Windows computers can become unstable or
low on resources.

• Ensure the computer's disk drive is not full.

• If you are attempting to access files on a network resource, ensure the network is
working properly and you have sufficient privilege.
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6.3 Resolving CNC Communication Problems

Note: Follow these instructions when troubleshooting communication problems with a
CNC that is connected directly to the computer. To troubleshoot communication
problems with the Dostek Model 440A Behind-the-Tape Reader (BTR), see Section
6.3.1 and Section 7 in the Dostek 440A BTR User Guide.

If you encounter a problem when you upload, download or drip feed:

• Write down, print or save a screen image of every error message displayed by the
software or by the CNC.

• If the CNC displays an alarm, find the alarm description in the CNC manual and
write it down or make a copy of the manual page.

• Use the sample device configuration provided for your CNC, and carefully read the
notes provided in the "Notes" tab. To use a sample configuration:

a) Start the Dostek DNC Configuration application.
b) On the File menu, click Import sample configuration.
c) Click the Notes tab and read the comments and instructions.

• Keep notes. Before you change anything (on the computer or the CNC), write
down the current setting, the new setting, and the reason for the change.

• View the Communication Testing and Troubleshooting help file (Navigator Help
tab) for detailed recommendations for typical communication problems. Go to the
'Problem Topics' section and find the topic heading that most closely describes
your problem.

6.4 Submit Configuration and Data Files

To diagnose your problem, Dostek may require a copy of your Dostek DNC configura-
tion files and/or a copy of one of your CNC part programs. You can submit files to
Dostek by email. 

To submit your Dostek DNC configuration files by email:

1. Start the Dostek DNC Configuration application.

2. On the File menu, point to Explore Folder, and then click Dostek DNC
Settings. The Dostek DNC "Settings" folder opens in a Windows Explorer
window.

3. On the Explorer window's Edit menu, click Select All. All files in the Settings
folder are selected.

4. On the File menu, point to Send To, and then click Mail Recipient. A new mail
message opens.

5. Type support@dostek.com in the To box.

6. Click Send.

Note:

› If the computer does not have an email application installed, instead copy the files
to another computer with email. 
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7 Technical Support

This section explains how to contact Dostek if you need help.

When contacting Dostek, provide the following information: 

• Your name, company name, telephone, and e-mail

• Your Dostek DNC software serial number and software version number. This infor-
mation is displayed when you click About in Dostek DNC's Help menu, and is also
recorded on the media page at the front of your printed manual. 

• If the CNC machine or the Dostek DNC software displays an alarm or error
message, write down the entire message. 

Free Technical Support 

Free technical support is always available by e-mail and fax:

e-mail: support@dostek.com 
Fax: 519-741-8669 
Web: www.dostek.com

Visit the Support page on the Dostek Web site for free access to the latest support
updates and help files. 

Remote Support and Training 

Remote technical support and training is a fast and cost-effective option. With remote
support, Dostek connects to you by telephone and to your computer by Internet.
Dostek can remotely configure your software, provide training or analyze problems. 

Telephone Technical Support 

Toll-free telephone technical support is available at no charge for a limited time after
your purchase. Thereafter, telephone support is available at reasonable cost. However,
don't hesitate to call; if your questions is simple, we can likely help you without
charge.

Toll free: 888-355-5735 (Toll free from USA and Canada) 
Direct: 519-742-5721
Hours: 8 am to 5 pm EST
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