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Trademark

"Dostek DNC/32" is a trademark of Dostek Incorporated.

Copyright

© Copyright 1998-2002, Dostek Incorporated.
All rights reserved.

No part of this Document may be reproduced in any form or by any means without prior
written consent of Dostek Incorporated, except when for the exclusive use of the licensee
and in accordance with the "Software License Agreement" below.

END-USER SOFTWARE LICENSE AGREEMENT - Dostek DNC/32TM

This Dostek End-User License Agreement is a legal agreement between
you (an individual or legal entity) and Dostek Incorporated for the
Software Product know as "Dostek DNC/32". The Software Product
includes the computer software and data files, and the printed and
on-line documentation. By installing or using the Software Product, you
agree to the terms of this agreement. If you do not agree to the terms of
this agreement, you may return the Software Product for a refund within
30 days of purchase.

COPYRIGHT

All title and copyrights in and to all components of this Software Product
(and all copies thereof) and the accompanying printed materials are
owned by Dostek Incorporated. This Software Product is protected by
United States, Canadian and international copyright laws and treaties.
You may make an unlimited number of copies of the software, provided
that such copies are used only for internal purposes in compliance with
the terms of this License Agreement and provided that such copies are
not republished or distributed to any third party. You may make an
unlimited number of copies of the printed or on-line documentation,
provided that such copies are used only for internal purposes and are not
republished or distributed to any third party. 

SOFTWARE PRODUCT LICENSE

This Software Product is licensed (not sold). This License Agreement
grants you the following rights:

1. Use of Software Product. Dostek grants you a non-exclusive license to
install copies of the Software on any number of computers provided that
the Software may be used on only one computer at any time for each
license purchased. A license for the Software may not be shared or used
concurrently on different computers.

2. Transfer. You may permanently transfer all of your rights under this
License Agreement according to the following provisions: (a) you transfer
the entire Software Product, including all component parts, media,
printed materials, any upgrades, and this License Agreement; (b) the
recipient agrees to the terms of this License Agreement;  (c) you do not
retain any copies of the Software Product or any component parts,
including any upgrades received for the Software Product; (d) the
Software Product is not labeled "Not for Resale" or "Demonstration
Copy".

3. Demonstration Copies. You may not resell or otherwise transfer the
Software Product if it is labeled "Not for Resale" or "Demonstration
Copy".

4. Components. The Software Product is licensed as a single product,
and its component parts may not be separated for transfer or for use on
more than one computer.

5. Rental or Lease. You may not rent, lease, or lend the Software
Product.

6. Reverse Engineering. You may not reverse engineer, de-compile or
disassemble the Software Product.

7. Termination. Without prejudice to any other rights, Dostek may
terminate this License Agreement if (a) you fail to comply with the terms
and conditions of this License Agreement, or (b) you fail to comply with

the terms of the Sales Invoice or Agreement of Sale for the Software
Product as issued by Dostek Incorporated or by an authorized Dostek
re-seller. On termination of this License Agreement by either party, you
must destroy all copies of the Software Product and all of its component
parts in your possession.

7. Temporary License. If you are granted a Temporary License that is
valid only until a specified Termination Date, this License Agreement
automatically expires on the specified Termination Date. On termination
of the Temporary License, you must comply with the conditions of
Termination (paragraph 6), or obtain a License Renewal from Dostek.

8. Upgrades. To qualify for a specially-priced Software Product Upgrade,
you must be properly licensed. Use of the upgraded Software Product is
subject to the terms of this License Agreement and the License
Agreement (if any) provided with the upgrade.

9. This License Agreement is governed by the laws of the Province of
Ontario, Canada.

LIMITED WARRANTY

Dostek warrants that the Software Product will perform substantially in
accordance with the accompanying documentation for a period of ninety
(90) days from the date of receipt. Dostek will make every reasonable
effort to correct any problem issues. This Limited Warranty is void if
failure of the Software Product results from abuse, improper application
or accident.

LIMITATION OF LIABILITY

Reasonable care has been taken in the design and preparation of the
Software Product. To the maximum extent permitted by law, in no event
shall Dostek Incorporated be liable for any indirect, special, incidental or
consequential damages whatsoever (including, without limitation,
damages for loss of business information, business interruption,
business profits, or any other loss) in connection with or resulting from
the use or the inability to use the Software Product. Dostek's entire
liability under any provision of this License Agreement shall be limited to
the amount actually paid by you for the Software Product.

NO OTHER WARRANTIES

Dostek Incorporated disclaims all other warranties and conditions, either
express or implied, including, but not limited to, implied warranties of
merchantability and fitness for a particular purpose.

Please contact Dostek Incorporated if you have any questions concerning
this License Agreement.

Dostek Incorporated
238 Westheights Drive

Kitchener, Ontario
Canada   N2N 1J9
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Introduction

Welcome to Dostek DNC, a versatile and easy to use CNC program management and
DNC communication program designed to work with the 32-bit Windows operating
systems (Windows 95 and later).

This manual explains how to use the Dostek DNC software. Information is organized into
five sections:

Section 5Communication . . . . . . . . . . . . . . . . . . .
Section 4Editor . . . . . . . . . . . . . . . . . . . . . . . . . .
Section 3File Manager . . . . . . . . . . . . . . . . . . . . .
Section 2Windows Fundamentals . . . . . . . . . . . . .
Section 1Software Overview . . . . . . . . . . . . . . . .

Refer to the Dostek DNC Configuration Guide for additional information including the
following topics:

v software installation and configuration
v configuring and managing device communication parameters
v creating (or removing) shortcuts from Windows desktop or menus
v connecting CNCs and other devices to the computer
v testing and troubleshooting communication
v DNC applications

Technical Support

Free telephone technical support is available for a period of 90 days from date of
purchase. Thereafter, free technical support is available by facsimile or email, and prior-
ity telephone technical support is available by annual subscription.

Dostek Incorporated Telephone: 519-742-5721
238 Westheights Drive Facsimile: 519-741-8669
Kitchener, Ontario email: support@dostek.com
Canada   N2N 1J9 internet: www.dostek.com

Using Dostek DNC on a Network

Although Dostek DNC is designed to work with a computer network, it is not designed to
run multiple workstations from a single copy installed on the network file server. Instead,
you must normally install Dostek DNC on each individual computer. This way, you can
use the software to transfer data to machine tools even when the network is shut down.

Dostek DNC includes many features that simplify operation in a network environment,
including File Manager support for multiple root folders, network file archiving, and a
Configuration Manager wizard to simplify backup and management of computer configu-
ration profiles.

Whether computers are networked or not, a software license is required for each
computer that uses Dostek DNC.  
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1 Software Overview

This section provides an overview of the features and organization of the Dostek DNC
software. 

Dostek DNC includes separate File Manager, Editor and Communication application
programs, plus a configuration program and a few utility programs. The multitasking
ability of 32-bit Microsoft Windows operating systems permits each application to be
used independently or to work together. There is no need to stop, close or exit the Editor,
for example, in order to use the File Manager or Communication program. The individual
application programs communicate with each other to perform the actions you choose.
For example, you can use the Communication application to transmit a file in any of the
following ways: 

v start the Communication application, open a file, choose Transmit, and click Start
v start the Editor application, open a file, and choose the Transmit command 
v start the File Manager, select one or more files, and choose the Transmit command 

File Manager - DDFM32

The Dostek DNC File Manager (Figure 1) provides the following features for managing
files:

v create, copy, rename and delete files and folders
v view or edit files
v transmit files to a CNC, or receive files from a CNC
v create and manage “job” files
v view documents related to a particular NC part program file
v search for files by file name, file content or file date

The File Manager is similar in appearance and function to the familiar Windows
Explorer, with many enhancements to simplify management of NC part programs. For
example:

v configurable security can restrict access to specific folders and specific file types and
disable commands that modify files or folders

v configurable “QuickButtons” provide shortcuts to common commands or to other
applications 

v multiple program files can be grouped together as a “job”

Editor - DEdit32

The Dostek DNC Editor (Figure 3) can edit multiple files of virtually unlimited size.
Commands are provided to search for and replace text (including a powerful Find All
command), to renumber and reformat CNC programs, to compare documents, to cut and
paste text within a document or to another document, and more.

Files can be opened for editing using the “Edit” command in the Dostek DNC File
Manager or Communication applications, or using the Editor’s “File Open” command.
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Communication - DDNC32

The Dostek DNC Communication program (Figure 4) transmits or receives files to or
from a CNC machine tool (or other device) that is equipped with a compatible serial
communication port. Features include: 

v file to be transmitted is previewed on the screen for browsing or searching, or for
selecting a transmit start or restart position

v multiple files can be grouped together as a single “job”
v received programs may be stored in files that are named automatically according to

the program name or part number received from the CNC
v each device can be assigned separate communication parameters, and device

communication parameters can be selected automatically according to the current
file location

Files can chosen for transmitting using the File Manager, Editor or Communication appli-
cation. Files can be received using the File Manager or Communication application.

Configuration - DConfig

The Dostek DNC Configuration program configures software options and device commu-
nication parameters. Refer to the Configuration guide for more information.

Terminal - DTerm32

The Dostek DNC Terminal program is provided to assist with troubleshooting or analysis
of communication problems. Refer to the Configuration guide for more information.

1.1 Security

Dostek DNC provides security features to restrict access to specific data and application
files stored on the local computer or network file servers. Access can be restricted to
specific file folders (disk directories) and specific file types, and users can be prevented
from modifying files and folders as well as Dostek DNC configuration settings. 

Refer to the Configuration guide for more information about security features, options
and precautions. 

Supervisor Mode

The File Manager "Supervisor Mode" permits full access to all Dostek DNC commands
and features, and  provides access to additional commands via the "Supervisor" menu.

For more information about Security and Supervisor Mode, refer to Section 3.9.
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2 Windows Fundamentals

This manual assumes you are familiar with Windows fundamentals. If you are a new
Windows user, you will find many excellent books and training materials available to
assist with learning. This section reviews just a few of the more important concepts.

Learn about Windows and Dostek DNC by experimenting. For example, try clicking,
right-clicking or holding the mouse over various screen features. Or experiment with
techniques you read about in computer books or magazines. But never experiment with
important data — always copy some files into temporary folders to experiment with. 

Keyboard

When viewing or editing files or lists, you can usually navigate through the data using
the arrow keys and the Home, End, Page Up and Page Down keys, as well as these
same keys in combination with the Ctrl key (by holding down the Ctrl key while pressing
the other key).

The Escape (or Esc) key will usually cancel a command, and the Enter key will usually
complete a command (equivalent to clicking the Cancel or OK button, respectively, with
the mouse). Press the Tab key to move the “focus” to the next control (text box, button,
file list, etc.). Many menu items have an associated short-cut key displayed in the menu.
For example, Ctrl+P (hold down Ctrl and press P) is usually the short-cut key for Print.

Selecting Text

To select text with the mouse, position the cursor to the start of text, press and hold the
left mouse button, drag the cursor to the end of text, and release the left mouse button.
To select text with the keyboard, position the cursor to the start of text using the arrow
keys, press and hold the Shift key, position the cursor to the end of text using the arrow
keys, and release the Shift key.

Selecting Files

To select a single file from a list, click on it with the left mouse button. To select a
sequential group of files, click on the first file, press and hold the Shift key, click the last
file and release the Shift key. To select non-sequential files, click on each file while
pressing the Ctrl key. To select all files, press Ctrl-A. To deselect all files, click on any
file. To deselect one file, click on the file while pressing the Ctrl key.

Cut, Copy and Paste

To move selected text or files, choose the Edit, Cut command from the menu, move the
cursor to the new location, and choose the Edit, Paste command. To copy selected text
or files, choose the Edit, Copy and Edit, Paste commands. Or use the shortcut keys:
Ctrl+X or Shift-Delete for Cut, Ctrl+C for copy, and Ctrl+V or Shift-Insert for Paste.

Drag and Drop

Selected text or files can usually be moved using “drag and drop”.

To move files or text using drag and drop, position the mouse cursor over the selected
item(s), press and hold the left mouse button, position the mouse cursor to the new
location, and release the left mouse button. To copy files or text, hold the Ctrl key down
while dragging and dropping. You can drag files from the File Manager and drop them
onto open windows or desktop icons. When using the Editor, you can move or copy text
by dragging it and dropping it at another position or in another document window.
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Figure 1 - Dostek DNC File Manager Features
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3 File Manager

To start Dostek DNC File Manager, click the Windows Start button and choose
Programs, Dostek DNC, Dostek DNC File Manager, or choose a shortcut you created.1 

3.1 Display Features

File Manager display features are illustrated in Figure 1. 

Tool Bar Provides shortcut icons for many frequently used commands. To
determine the function for a particular icon, position the mouse
cursor over the icon and wait for the “tool tip” message to appear.

Status Bar Displays status information and messages.

Folder Window Displays file folders in a hierarchical “tree” format. “Branches” may be
expanded or collapsed by clicking the mouse on a “node” ("+" or "-")
or by double-clicking on a folder. The top-level folder in a branch is
referred to as the “root folder” (Section 3.1.3).

File Window Displays a list of files stored in the current folder. One of several view
modes may be selected by the View menu or toolbar icons. The file
filter option may be set to display all files or only files of specific
types (file extensions). Additional display options are available by
choosing "View Preferences" from the View menu (Section 3.1.1).

Quick Buttons If enabled, QuickButtons appear at the right edge of the File Manager
window, and provide shortcuts to frequently used commands or other
applications. To add or modify QuickButtons, choose “Options” from
the Supervisor menu (Section 3.10.3).

Context menu (not illustrated) A “context menu” appears when the right mouse
button is clicked while the mouse pointer is over certain File Manager
features (such as the folder window or file window). The context
menu displays commands appropriate for the current context.

3.1.1 Display Options

The File Window provides several view mode options, including “Small icons” and
“Details”. Choose a file display mode using the View menu or by clicking a toolbar icon.

When the File Manager is started, files are sorted by name in ascending order. To select
a different sort criteria, choose “Arrange” from the View menu, and pick one of the sort
options: name, size or date. To alternate between ascending and descending sort order,
choose the sort option again. When using “details” view mode, you may also change sort
criteria by clicking on a column header, and alternate between ascending and descend-
ing order by clicking the column header again. 

To configure File Manager preferences, choose “View Preferences” or “File Filter” from
the View menu (Section 3.10.2).

The File Filter option setting determines whether all files or only files with specific file
extensions are displayed (CNC files, document files, binary files or other files). File
extensions are configured by the Dostek DNC Configuration program.
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3.1.2 Refreshing the Display

Other Windows applications can create, delete, modify or rename files or folders within
the root folders the File Manager is displaying. File and folder changes made externally
are not displayed by the File Manager until the next time the display is refreshed. If you
create a new NC program with your CAD/CAM software, for example, you may not be
able to access the file until the display is refreshed. The File Manager display is
refreshed by any of the following events: 

v the Refresh icon in the toolbar is clicked
v the "Refresh" from the File Manager's "View" menu is refreshed
v a different folder is opened
v the Folder Window title bar is clicked (only the Folder Window is refreshed)
v the File Windows title bar is clicked (only the File Window is refreshed)
v Supervisor mode is enabled or disabled

The File Manager automatically detects external changes made within the current folder
(if the folder is on a local drive) and indicates that refresh is required by changing the
color of the File Window title bar to yellow. External changes to a network drive can not
be detected.

3.1.3 Root Folders

Access is restricted to files and folders in one or more "Root folders" listed in the Folder
Window. Access is permitted to all files and folders below each root folder. If "My
Computer" is the root folder, access to all files and folders on all drives (local and
mapped network drives) is permitted.

To add, remove or rearrange root folders, refer to Section 3.10.4.

3.1.4 File Names

The maximum length of a Windows 95/98/NT file name is 254 characters (including the
drive and path). File names can include A to Z, 0 to 9, space, any ASCII character
greater than 127, and any of the following characters:

$ % ' - _ @ ~ ` ! ( ) ^ # & + , ; = [ ] 

Multiple periods are permitted. Spaces are not permitted at the start or end of a file
name. Following are some examples of valid file names:

O1234.TAP
O1234 (75X438-22-001 UPPER CONTROL BRACKET).TAP
75X438-22-001.OP#T-1.REV4B.19990122

The computer file name does not need to be the same as the CNC program name or
number, and the CNC program number stored in each file does not need to be unique. 

If you include the computer file name in the first line of each file, Dostek DNC can be
configured to automatically store received data in the correct file (Section 5.3.1).

Performance of some Dostek DNC features may be adversely affected by excessive use
of long file names because of additional memory and processing requirements.
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3.2 Finding and Selecting Files

Before you can use a file, you must open the folder it is located in and select the file.
You can use folders to organize files according to criteria such as machine, product or
customer. Files can be selected manually or by searching for a matching file name, file
content or file date.

3.2.1 Navigating Folders

Access is restricted to files and folders within the "Root folders" listed in the Folder
Window.

A folder can be selected (opened) in any of the following ways:

v click a folder in the folder window
v if the folder window has "focus" (a folder is visibly highlighted), you may navigate

folders using the arrow keys (up, down, left, right)
v to expand or collapse a branch in the folder window (to display sub-folders), click the

mouse on a node or double click a folder
v double-click a folder in the file window
v if the file window has "focus" (a file is visibly highlighted), select a folder with the up

and down arrow keys, and press Enter
v click the "Up one level" toolbar icon to go up one folder level

3.2.2 Selecting Files

Files can be manually selected using either the Windows standard file selection mode or
the Check Box file selection mode:

Select or deselect files by clicking the check box.Check box

To select a single file, click on a file name with the left
mouse button. To select a sequential group of files, click
on the first file name, press and hold the Shift key, click
the last file name and release the Shift key. To select
additional files in any order or to deselect a single file,
click on a file name while pressing the Ctrl key. To
deselect all files, click on any file.

Windows
standard

To change the file selection mode, choose “View Preferences” from the "View" menu
and change the "Check Boxes" check box in the "File List Options" group.

To select all files, clear all file selections or invert file selections, choose "Select All
Files", "Clear Selections" or "Invert Selections" from the "Search" menu.

3.2.3 Go to File

Choose "Go to File" from either the "File" or "Search" menu (or press Ctrl-G) to quickly
find a specific file by name. As you type each letter of the desired file name, the file
selection is progressively moved to the closest matching file name.
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Figure 2 - Search Criteria and Search Results Forms

3.2.4 Searching

To search for files that match any combination of file name, file content or file date crite-
ria, choose one of the search commands from the "Search" menu. A form with three tabs
(Figure 2 upper) is displayed for input of search criteria. Enter the search criteria and  
click the "Go to next" button to go directly to the next matching file, or click the "Find All"
button to display a list of all matching file names.

Four search commands are provided: Search, Name Search, Contents Search and
Date/Time Search. Each command displays the search criteria form in a different way.
The Search command activates the search criteria form with all criteria used in the
previous search. The Name Search, Content Search and Date/Time Search commands
activate the corresponding tab on the search criteria form, and clear the criteria settings
on all other tabs. 

Regardless of which search command is used, a combination of search criteria may be
specified on any tab. Check marks appear on any tab where search criteria are entered.
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File Location

To specify a search location, choose the "File Name and Location" tab and specify a
location in the "Look in" field. Check "Include subfolders" to also search in sub-folders.
Check "Only search selected files" to only include files that are already selected.

Name Search

To locate files with a specific file name, choose the "File Name and Location" tab and
enter a file name specification in the "Matching name" field. The “*” (asterisk) character
is a “wild card” which may be used as follows:

1234* matches 1234.NC, 1234A.TAP, 123456, etc.

1234*.TAP matches 1234A.TAP but not 1234A.NC

*1234* matches 1234.NC, ABC-1234-DEF.TAP, etc.

Contents Search

To locate files containing specific text, choose the “Contents” tab and specify the text to
search for. You can search for any information that is stored in the file, such as a
specific part number, customer name, tool, or other information. Check "Show all match-
ing lines" for a detailed search result report that display each matching line in every
matching file. Check "Match case" to find text with the same combination of upper case
and lower case characters. Check “Quick contents search” to speed searching by
restricting the search to the first 4000 characters of the file.

Date/Time Search

To locate files created, modified or accessed within a specific date or time, choose the
"Date/Time" tab and specify a date or time range.

3.2.5 Search Results

If "Find All" is chosen, the search results form is displayed (Figure 2 lower) and the
following choices are available:

Highlight one or more files and click "Deselect". The
highlighted files are deselected in the File Manager's file
list.

Deselect files

Highlight one or more files and click "Select". The
highlighted files are selected in the File Manager's file list.
Click "All" to alternately highlight all files or no files.

Select files

Double-click a file name, or choose a file and click "Go
to".

Go to file

Cumulative Selection

When the "Cumulative" item in the Search menu is checked, files are selected in
addition to any files that are already selected. When not checked, current file selections
are cleared and only the matching files are selected.
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3.3 Viewing, Editing and Comparing Files

To view or edit one or more files, select the file(s) and choose “Edit” or “View” from the
File menu or context menu, or click the appropriate QuickButton (if available). Files can
also be edited by dragging and dropping them on either the Dostek DNC Editor desktop
icon or an open editor window. To compare two files, select the files, choose "Edit" and
use the Editor's file comparison function described in Section 4.8.

When viewing a file, choose “Previous file” or “Next file” from the File menu (or click the
Previous or Next icon in the View window tool bar) to view the previous or next file. If
more than one file is selected when View is chosen, "Previous file" and "Next file"
display the previous or next selected file.

The Viewer and Editor both provide a “Find All” command to selectively view lines that
match a text search. For example, you can specify "G92” to view all occurrences of G92
or specify "(" to view all comments. Double click the mouse on any line in the search
result list to jump directly to that line in the document (or select a line and choose the
“Go to” button).

3.3.1 Viewing Setup or Tooling Information

The "Find All" command provides a convenient way to display and print setup sheets
using information that is systematically stored as comments in CNC program files. For
example, if tooling information is stored throughout a CNC program file in comments
such as “(TOOL 5 - 0.5 IN END MILL)”, for example, you can display just tooling
information by choosing “Find All” and specifying “(TOOL“ as the search text. The results
can be viewed or printed.

To use setup sheets that include drawings, sketches or photographs, refer to “Viewing
Related Documents”, below.

3.3.2 Viewing Related Documents

Choose “View Documents” from the File menu to view documents related to the selected
CNC program file. A list of matching document files will be displayed.

Related documents are located by searching specified file locations for files with names
matching either the CNC program name or a name specified as a comment in the first
few lines of the file. Before using the "View Documents" command, document types and
file locations must by configured using the Dostek DNC Configuration application.

3.4 Copying Files

The File Manager supports Windows standard methods for copying files, including cut,
copy, paste and drag and drop (Section 2). A confirmation message is displayed before
replacing any existing file. For security reasons, files may not be copied to or from a
diskette unless the diskette drive is specified as a Root Folder (Section 3.1.3).

When you drag files or folders, a menu appears when you release the mouse button.
Choose "Copy" to add a copy of the items to the new location, choose "Move" to move
the files from the previous location to the new location. Move is the default if the new
and original locations are on the same drive or the Ctrl key is pressed when the mouse is
released, and Copy is the default when the new and original locations are on different
drives.
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3.5 Creating New Files and Folders

To create a new file, a new folder, a new job file, or a new duplicate copy of an existing
file, choose “New” from the File menu and choose an option from the sub-menu. New
files or folders are created in the current folder.

3.5.1 Create New Folder

Choose "Folder" from the "New" sub-menu to create a new folder, and enter a name for
the new folder. 

3.5.2 Create New File

Choose  "New File" from the
"New" sub-menu to create a new
file. A file type can be specified by
typing a file extension, or by
choosing from the "Type" list. You
are not permitted to create a file
type that does not match the
current "File Filter" setting (Section
3.10.2).

Click "Create" to create a new
empty file, or click "Edit" to open and edit a new blank document.

A new file can also be created by choosing "New" from the Editor "File" menu.

3.5.3 Create Duplicate Copy of File

Choose  "Duplicate File" from the "New" sub-menu to create a new copy of an existing
file. A file type can be specified by typing a file extension. If a file extension is not typed,
the new file is created with the same file type as the existing file.

A copy of an existing file may also be created by opening the file with the Editor and
choosing the "Save As" command from the "File" menu.

3.5.4 Create New Job File

A "Job" file is a file containing a list of file names. When a job file is transmitted, the files
named in the job file are transmitted in the order they are listed.

To create a new job file, select one or more files and choose "New Job File" from the
"New" sub-menu. To create a new empty job file, choose "New File" and specify file type
"Job File". A duplicate of a job file can also be created (Section 3.5.3).
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3.6 Printing

To print selected files while using the File Manager, choose “Print” from the File menu or
click the Print icon on the tool bar. Printing is performed by the Dostek DNC Editor. If the
Editor is already open when you print a file using the File Manager, it may not respond to
key stokes for a few seconds while setting up the print task. If the Editor is not open, it
will be loaded temporarily in a minimized state that is not visible on the screen.

3.7 Deleting Files and Folders

Choose "Delete" from the File menu or press the [Delete] key to delete files you have
selected. If delete confirmation is enabled, a message appears asking you to confirm
that you wish to delete the files. Delete confirmation is controlled by a check box on the
Recycle Bin properties form.

When a folder is deleted, all files and sub-folders are also deleted.

Recycle Bin

Files deleted from the computer's local disk drives are moved to the Windows Recycle
Bin (if the Recycle Bin is enabled). Files deleted across a network connection are
not protected by the Windows Recycle Bin. 

Recycled files on local drives can usually be recovered by double-clicking the Recycle
Bin icon on the Windows desktop. However, recycled files are available for a limited
time because Windows automatically removes older files from the Recycle Bin to make
room for newer files.

To delete files directly without moving them to the Recycle Bin, hold the Shift key down
while pressing the [Delete] key.

Refer to the Windows manual or on-line help for more information about the Recycle
Bin.

3.8 Transmitting and Receiving Files

To transmit selected files, choose “Transmit” from the File menu or click the Transmit
QuickButton (if available). A file may also be transmitted using the Editor's Transmit
command. 

To receive files, select a destination folder and choose “Receive” from the File menu or
click the Receive QuickButton (if available). To replace an existing file, select the file
and choose “Receive (Replace)” from the File menu.

The Dostek DNC Communication application (Section 5) is launched when a Transmit or
Receive command is executed. 
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3.8.1 File Archive

The Archive Store and Archive Retrieve commands transfer files to and from a desig-
nated archive storage area. 

Dostek DNC is often used in a network environment where CNC program files are stored
on a network file server. To prevent machine down time, program files are often stored
on the computer’s local hard drive so they can be used even when there is a network or
server problem. The File Archive commands let you store the master copy of CNC
program files on a file server and store a working copy of some or all of the files on the
shop-floor computer(s). 

To retrieve a file from the Archive, choose "Archive" from the File menu and pick
"Retrieve" from the Archive sub-menu. Enter the file name to search for, and click
Search. The "*" character may be used as a "wild card". When the search is complete, a
list of matching files is displayed. Select one or more files in the list and click "Retrieve
Selected". To retrieve all matching files, click "Retrieve All".

To store files to the file archive, select the files to store, choose "Archive" from the File
menu and pick "Store" from the sub-menu. 

One level of sub-folders can be used to organize files in the Archive. Files are stored to
or retrieved from the Archive sub-folder whose name matches the current folder, or from
the Archive root folder if there is no match.

3.8.2 Work In Process

Dostek DNC provides two ways to restrict shop-floor access to only program files
required for work currently in process:

v set up a file archive (Section 3.8) and configure security options to require the
Supervisor password for the Archive commands; designated staff can retrieve files
by choosing the Archive command and entering the Supervisor password

v set up separate "work in process" folders on the network file server for each
shop-floor computer, and restrict Dostek DNC access to these folders only;
designated staff with access to the CNC file library can make files available to the
shop floor by copying them to the work in process folders
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3.9 Security

If Dostek DNC security is enabled, use of certain File Manager features and commands
is restricted. The security icon on the tool bar indicates the current state of security:

Dostek DNC security features are disabledGhosted

Dostek DNC is operating in “Supervisor” mode; security is
temporarily disabled

Depressed

Dostek DNC security is enabledNormal

To “log on” to supervisor mode and temporarily disable Dostek DNC security, click the
security icon on the tool bar or choose “Supervisor Mode” from the File menu, and enter
the supervisor password.

To “log off” from supervisor mode and enable Dostek DNC security, click the security
icon or choose “Supervisor Mode” again.

If you choose a restricted command while security is enabled, File Manager will prompt
you to enter the “Supervisor” password. You have three options:

v choose the Cancel button or press Escape to cancel the command
v check the “Log on to supervisor mode” check box and type in the password to enter

supervisor mode and temporarily disable security (until supervisor mode is
terminated)

v clear the “Log on to supervisor mode” check box and type in the password to
execute the command; security will be disabled for the duration of the selected
command, and will be restored when the command is completed

To configure Security options, refer to Section 3.2 of the Configuration guide.

3.10 File Manager Options

To configure File Manager options, choose "Options" from the "Supervisor" menu to
display the Options form, and click on a tab to choose one of three option categories:
View Preferences, File Filters or QuickButtons. View Preferences and File Filters options
can also be accessed directly from the View menu.

3.10.1 View Preferences

Choose the "View Preferences" tab to change how the File Manager displays file and
folder information. Preferences are organized into two groups: Display options and File
List options. Display options let you hide the tool bar, QuickButtons or Folder Window,
enable touch screen features, use larger fonts or tool bar icons, and disable drag and
drop features. File list options let you set preferences for the File Window. 

3.10.2 File Filter

Choose the "File Filters" tab to change which files the File Manager displays in the file
list window. You can choose to display all files, or only specific file types. File types are
configured using the Dostek DNC Configuration program (Configuration guide, Section
3.3).
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3.10.3 QuickButton and Utility Menu Configuration

Choose the "QuickButtons" or "Utility Menu" tab to add, remove or change QuickButton
or Utility menu items.

Click ">" or "<" to select the next or previous item for editing. Click "Remove" to delete
the current item. Click "Move >" or "< Move" to move the current item up or down in
order.

To create a new item, click "Add" or "Insert".

Additional options are provided to select QuickButton button and caption size and color,
and to arrange QuickButtons in one or two columns.

When creating a QuickButton, choose a pre-defined command from the list, and enter a
suitable caption. To create a two-line caption, position the cursor in the Caption field and
press "\" or click the "Split" button.

Check the "... Supervisor ..." check box to restrict use of a QuickButton or Utility menu
item.

Refer to Appendix B, "Advanced QuickButton/Utility Functions" for more information
about using a QuickButton or the Utility menu to launch an external application.

3.10.4 Root Folders

To add, remove or change root folders, select Supervisor mode and choose "Root
Folders" from the "File" menu (or click the "Root Folders" toolbar icon).

Choose "My Computer" to make all drives available, including local and mapped network
drives. Use the "Move" buttons to rearrange the order of the folders, or use the "Perma-
nent" button to save changes in the Dostek DNC configuration file.

"Network Neighborhood" is not permitted as a root folder, but you can designate a
network folder as a root folder by choosing "Add" and selecting "Network Neighborhood"
in the "Browse for Folder" dialog.
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Figure 3 - Dostek DNC Editor Features 
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4 Editor

The Dostek DNC Editor application can be started from Windows or from either the
Dostek DNC File Manager or Communication applications in the following ways:

v choose “Dostek DNC Editor" on the Windows Start or Programs menu
v click the Dostek DNC Editor shortcut you create on the Windows desktop
v drag one or more files from another application and drop them on the Dostek DNC

Editor desktop shortcut
v choose “Edit” on the Dostek DNC File Manager “File” menu
v choose "New file" on the Dostek DNC File Manager "File" menu
v click a Dostek DNC File Manager "Edit" QuickButton you create
v choose “Edit” on the Dostek DNC Communication “File” menu

4.1 Preferences

To change Editor preferences, choose "Preferences" from the File menu. You can set
the font, color, tab width and block skip character (Section 4.9.3).

4.2 Editing Multiple Documents

Editor features are illustrated in Figure 3. A standard Windows "multiple document inter-
face" (MDI) is used to permit documents to be displayed as cascading windows, tiled
windows (vertical or horizontal), or a single maximized window. In addition, a split
window mode permits editing two portions of the same file simultaneously.

Choose an open document by picking from the list provided on the "Window" menu, or
press Ctrl+Tab to select the next open document. When windows are tiled or cascaded,
you can select a document by clicking on the document's title bar or by clicking
anywhere in the document's window.

A document can be minimized, maximized or closed by clicking on the standard
Windows icon in the document's title bar.

4.3 Creating, Opening and Saving Documents

Documents (files) can be opened, created, saved or closed by choosing commands from
the Editor's File menu or by clicking the corresponding icon on the Editor's tool bar.
Choose "Open" to open an existing document, "New" to create a new document, or
"Save" to save the current document. 

To close the current document, choose "Close" from the File menu or click the Close
icon in the document's title bar (X). If changes were made to the document but were not
saved, you will be asked if you wish to save changes before closing the document. To
close all open documents, choose "Close all windows" from the Window menu.

To save the current document as a different file name, choose "Save As". You can use
Save As to create a new file or to replace an existing file. If you make changes to a
document and wish to keep both the original document and the modified document, use
Save As to save the modified document under a new name (the Save As command
does not update the original file before saving the document to the new file).

Documents can also be created or opened when starting the Editor (as explained at the
start of Section 4).
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4.3.1 Precautions

The Dostek DNC Editor actually edits a copy of the document stored in an area of
memory called the Edit Buffer, rather than directly editing the document's disk file. The
original file is not modified until the information in the edit buffer is saved to disk. This
means that changes will be lost if the computer is turned off or the power fails. It also
means that you can recover from some errors by closing a modified document without
saving it, thereby retaining the original document. When creating a new document or
making extensive changes to an existing document, periodically save the edit buffer to
disk by choosing the "Save" command from the File menu, by pressing the Save short-
cut key (Ctrl+S), or by clicking the Save icon in the tool bar.

When changes are made to the edit buffer, the "Save" icon on the tool bar is enabled. If
there have been no changes since the document was opened or saved, the "Save" icon
is disabled.

4.4 Undo/Redo

Up to 256 edit keystrokes can be "undone" by clicking the Undo icon on the tool bar or
by choosing "Undo" from the Edit menu. To undo a command that copied or moved text
from one document to another, use Undo in both documents. Choose Redo to reverse
Undo commands. 

4.5 Entering, Inserting and Deleting Text

To enter text into a document, select the document, position the cursor to the insertion
point, and start typing.

To delete text, press the Backspace or Delete key, or select a block of text and press the
Delete key. To delete a word, delete a line, delete from the cursor to the end of the line,
or delete all text in the entire document, choose "Delete" from the Edit menu and pick a
delete option from the sub-menu (or use the short-cut key listed in the sub-menu).

To replace a block of text with new text, select the text to be replaced and start typing.

Insert/Overstrike Mode

Insert/Overstrike mode determines if characters you type are inserted into existing text
or replace (type over) existing text. Press the [Insert] key to alternate between Insert
mode and Overstrike mode. Insert mode is indicated by a narrow cursor, and overstrike
mode is indicated by a wide cursor.

If the [Enter] key is pressed while Overstrike mode is on, the cursor is positioned to the
first character of the next line. If the [Enter] key is pressed while Insert mode is active, a
new line is created below the current line, and text to the right of the cursor is moved to
the start of the new line.

Splitting, Joining and Inserting Lines

To insert a blank line below the current line, ensure Insert mode is active, then press the
[End] key to position the cursor to the end of the line and press [Enter]. To insert a blank
line above the current line, press [Home] to position the cursor to the start of the line and
press [Enter].

To split a line into two separate lines, ensure Insert mode is active, then position the
cursor to the break point and press [Enter]. To join two lines, position the cursor to the
first line and press [End] then [Delete].
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4.5.1 Inserting Files

To insert a file into the current document, choose "Insert" from the File menu, choose
"Insert", "File" from the Edit menu, or click the Ctrl+I or Ctrl+F1 short-cut key. The
chosen file will be inserted into the current document at the current cursor position. If the
cursor is at the start of the line, the file will be inserted above the current line; otherwise,
the file will be inserted below the current line. The inserted text is automatically selected
(highlighted). Choose the "Jump to Start" or "Jump to End" commands from the Edit,
Block menu to go to the start or end of the inserted text. While the inserted text is still
selected,  use the Edit, Undo command or press Delete to remove the text.

For convenience, DEdit32 remembers the last folder and file name inserted during each
edit session. To set a default initial folder for File Insert, choose File, Preferences and
select the "Other" tab.

4.6 Selecting, Copying and Moving Text

Text can be selected using standard Windows techniques. Selected text can be deleted,
replaced, cut or copied to the clipboard, or dragged and dropped to a new location.

To select text with the mouse, position the cursor to the start of text, press and hold the
left mouse button, drag the cursor to the end of text, and release the left mouse button.
To select text with the keyboard, position the cursor to the start of text using the arrow
keys, press and hold the Shift key, position the cursor to the end of text using the arrow
keys, and release the Shift key.

To delete selected text, press the Delete key. To replace selected text, start typing or
paste replacement text from the Windows clipboard.

To cut selected text to the Windows clipboard, choose "Cut" from the edit menu or
context menu (click the right mouse button), or use either the Ctrl+X or Shift+Delete
short-cut key. Text that is "cut" is removed from the original document. Use "cut" to
move text to another location.

To copy selected text to the Windows clipboard, choose "Copy" from the edit or context
menu or use the Ctrl+C short-cut key. Text that is "copied" is not removed from the origi-
nal document.

Text that is cut or copied to the Windows clipboard can be "pasted" into the current
document, another open document, or another Windows application. To paste the text
from the Windows clipboard, position the cursor to the insertion point and choose "Paste"
from the Edit or context menu, or use the Ctrl+V or Shift+Insert short-cut key.

Drag and Drop

The mouse can be used to drag selected text to a new location, including a different
document window. Move the mouse pointer over the selected text and press and hold
the mouse button down while moving the mouse cursor to a new location. Release the
mouse button when the cursor is positioned to the new insertion point.

To copy text from one document window to another using drag and drop, press and hold
the Ctrl key while pressing and holding the mouse button. To cancel the drag and drop
operation, press Escape before releasing the mouse button.

Block Selection

In addition to Windows standard text selection, the Dostek DNC Editor lets you mark a
block of text by choosing "Block" from the Edit menu. The "mark block" feature lets you,
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for example, mark the start of a block, use the Find command to locate text, then mark
the end of the block.

To mark a block, choose "Mark Begin" and "Mark End" from the Edit Block sub-menu (or
press the F5 and F6 short-cut keys). Choose "Jump to Start" or "Jump to End" from the
Edit Block sub-menu (or press Ctrl+F5 or Ctrl+F6) to jump to the start or end of the
block. The marked block is highlighted each time you use a Block command, and
highlighting is removed the next time a key is pressed.

Inserting Text From Other Applications

To insert text from another application, cut or copy the text into the Windows clipboard
and paste it into the Editor document.

4.7 Searching and Replacing

The Dostek DNC Editor provides Find, Find All and Replace commands to search for
and replace text.

4.7.1 Find

To search for text within the current document, choose "Find" from the Edit menu, press
the Ctrl+F short-cut key, or click the Find icon on the tool bar.

4.7.2 Find All

To search for all occurrences of text within the current document, choose “Find All” from
the Edit menu, press the F4 short-cut key, or click the Find All icon on the tool bar.

When finished searching, the Editor displays a search report listing each line in the
current document that contains the specified text, as well as the line number at which the
text is found. Click on any line in the search report to position the document window to
view the matching text in context. Double-click any line to also close the report window. 

Following are some example applications for the Find All command:

display a tool list for an NC program, assuming a
comment of the form “(TOOL 5 - 0.5 IN END MILL) “
is included at each tool change in the program

(TOOL

display all comments in an NC program(

display every use of a G98 code in an NC programG98

Click the Print button on the Find All report to print the results. Refer to Section 3.3 for
additional information about uses for the Find All command.

4.7.3 Replace

To replace text within the current document, choose “Replace” from the Find menu, or
press the Ctrl+R short-cut key. The Undo command may not be able to reverse all
changes made with the Replace command. Save the document before replacing text so
you can restore it in case of errors or unwanted changes.
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4.8 Comparing Documents

Choose the “Compare” command from the editor's File menu to compare any two open
documents. The Compare form is displayed (Figure 4) with two drop-down lists contain-
ing the names of all open documents. Choose any two documents and click the
'Compare' button (or choose "Compare" from the Compare form's menu, or press Ctrl+O
on the keyboard).

Comparison options are provided to ignore capitalization, white space or N-block
numbers. Results can be displayed side-by-side with highlighted text or as a simple
one-column report. Commands are provided to quickly view the next or previous area of
difference, or to jump back and forth between the Compare and Edit forms. Comparison
results may be transferred to the editor (to a new document) for manipulation or printing.
And results may also be copied and pasted into other applications.

Figure 4 - Editor File Comparison Form

4.8.1 Viewing Options

Choose "View" from the Compare form's menu to select viewing options such as results
display format, split-screen orientation, form location and file compare order. 

You may change the size and screen position of the Compare form, but you may not
minimize the form.

Display Format

Results can be displayed in a split-screen format with highlighted text or as a simple
one-column report.

Choose "Split - All Text" to view both files in a split-screen format with differences
highlighted by colored text. Lines that differ between the two files are highlighted by blue
underlined text. Differences within the same line in both are highlighted by bold red
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underlined text. All text between the first difference within a line and the last difference
within a line are highlighted, even if some of the text is the same within the highlighted
areas.

Choose "Split - Differences only" to view only the differences in a split-screen format.

For split-screen format reports, choose "Vertical split" to view results side-by-side, or
choose "Horizontal split" to view results one file over the other..

Choose "Report - Differences only" to view only the differences in a single-column
report. Each area of difference is identified with the file name, line number range, and
the lines that are different. Changed lines are marked "!", and added and removed lines
are marked "+" and "-" respectively.

If "Split-All text" format is selected and either file is larger than 100,000 bytes, "Split -
Differences only" format is used instead.

Lines that differ between the two files are highlighted by blue underlined text. Differ-
ences within the same line in the two files are highlighted by bold red underlined text. All
text between the first difference on a line and the last difference on a line are
highlighted, even if some of the text is the same within both lines.

On Top of Editor

Check the "On top of Editor" menu to automatically position the Compare format on top
of the editor each time the form is displayed. When this option is checked, the form is
sized and positioned so it covers the entire editor form, except for the title bar, effec-
tively hiding the editor.

Even when the "On top of Editor" option is checked, the Compare form may be manually
re-sized and repositioned.

When the "On top of Editor" option is not checked, the size and position of the Compare
form is saved and restored the next time the form is used.

Swap Files

Choose "Swap Files" from the Compare form's File menu, or click the Swap icon in the
toolbar, to swap the file selection between the two drop-down file lists, effectively
exchanging the order of file comparison and display.

4.8.2 Comparison Options

Choose "Options" from the Compare form's menu to
choose file comparison options. Options are enabled
when checked. Choosing an item alternately enables
(checks) and disables the option.

Check "Ignore Case" to ignore differences in capitaliza-
tion of letters. When checked, "ABC" and "Abc" are
considered to be identical.

Check "Ignore Spaces" to ignore differences in space and
tab characters within each line, and to ignore blank lines. When checked, "N0010X2.0"
and "N0010 X2.0" are considered to be identical.

Check "Ignore Block numbers" to ignore N-block numbers. When checked,
"/N0010X2.0" and "/N0020X2.0" are considered to be identical.
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Check "Word highlight" to highlight whole "words" that are different. For this purpose, a
"word" is considered to be a sequence of letters or a sequence of numbers (including
plus, minus and period). When checked, differences "X-1.23Y4.56" and
"X-1.93Y4.56" are instead highlighted as "X-1.23Y4.56" and "X-1.93Y4.56".

Check "Line numbers" to display the number of each line when the "Split - All text"
display format is chosen. 

Check "Automatic compare" to automatically compare or re-compare files.

When "Automatic compare" is not checked, the "Compare" button must be pressed (or
"Compare" must be chosen from the File menu, or Ctrl+O must be pressed) to compare
the selected files and display the results. If a view or compare option that could affect
the comparison result, the form is cleared and "Compare" must be clicked to re-compare
the files.

When "Automatic compare" is checked, files are compared automatically when the form
is loaded and exactly two files are open in the editor, and files are automatically
re-compared each time a significant view or compare option is changed.

4.8.3 Navigate and Search

When viewing comparison results in "Split - All text" display format, quick navigation to
the next or previous area of difference is provided by commands in the View menu,
buttons on the toolbar, and by keyboard shortcuts (Ctrl+N and Ctrl+B).

To scrolling up and down a page at a time while viewing results in any display format,
press the PgUp or PgDn key on the keyboard or click the "Scroll Up" or "Scroll Down"
buttons on the toolbar. To jump to the start or end of the results report, press Ctrl+Home
or Ctrl+End on the keyboard.

To search for text, choose "Find" in the Search menu, click the Search button in the
toolbar or press Ctrl+F on the keyboard. When viewing results in a split-screen display
format, first select a file to search by clicking anywhere in the file's result window.

To repeat a search, choose "Find Next" in the Search menu or press F3 on the
keyboard.

4.8.4 Switching Between Edit and Compare

To return to edit mode and retain the current compare results, choose "Jump to Edit
mode" in the File menu, click the Editor icon in the toolbar, or press Ctrl+G on the
keyboard.

If the "Split - All text" display format is selected, the Dostek DNC editor automatically
displays the two compared documents tiled side by side or on top of each other accord-
ing to the Compare options (Vertical split or Horizontal split). Each edit window is
automatically scrolled to the same position within the document as currently viewed on
the Compare form. To jump back to the comparison results, simply click the Compare
button in the toolbar. If either compared document is closed or modified while in edit
mode, a suitable warning message is displayed the next time the comparison results are
viewed.

To return to edit mode and clear the current compare results, choose "Close" in the File
menu, click the "Close" button in the toolbar, press Ctrl+X on the keyboard or click the
Compare form's [X] button.
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4.8.5 Saving and Printing Results

Comparison results may be transferred to an editor document for saving, manipulation,
printing or exporting to other software applications such as memos or engineering
documents. To transfer results, choose "Edit/Print Report" in the File menu, or click the
Report icon in the toolbar. The Compare form closes and a new document containing the
comparison results is opened in the editor. Save or print the new document in the normal
manner. Single-column landscape printing is recommended for split reports. It may be
necessary to choose a smaller printer font to fit a split report to the width of the page.

Portions of results may also be exported by copying and pasting text from the Compare
form using the Windows clipboard. To copy text to the clipboard, select the text with the
mouse or keyboard and press Ctrl+C (or click the right mouse button and choose "Copy"
from the pop-up menu). Switch to the other application or document and press Ctrl+V to
paste the Windows clipboard into the application.

4.8.6 Special Applications

Other applications can access a plain-text copy of the most recent file comparison report
by opening file "Compare.log" in the "Dostek DNC" folder. Or, applications can create
comparison reports using the Dostek DNC file comparison report generator (contact
Dostek for more information).

Page 26 Dostek DNC

 



4.9 CNC Program Formatting

The Dostek DNC Editor provides the following CNC program formatting functions:

v add, update or remove block sequence numbers
v expand or compress lines (insert or remove spaces)
v reformat numeric values
v convert to upper case
v remove unprintable characters
v remove leading and trailing spaces 
v insert or remove block skip characters

4.9.1 Block Sequence Numbers

To renumber (re-sequence) a program, choose “Block numbers” from the Tools menu,
select the "Insert/Replace" option and specify the following parameters:

Choose the scope or range of block numbering: selected
text only, from cursor to end of document, entire
document.

Scope

Enter the interval between blocks that are numbered. For
example, enter 10 to number every 10th block.

Interval

Enter the amount to increase each subsequent block
number. For example, enter 10 to number blocks 100,
110, etc.

Increment

Enter the first block number to use (for example, 1 or 10).
If a fixed number of digits is required for the block
number, add leading zeros to the number (for example,
0010).

Start block

Type the block number identification character(s) or
choose from the list.  

Block Number ID

Block sequence numbers are added according to the following rules:

v lines that start with any character specified in "Omit lines..." field of Transmit Options
(Communication tab, global configuration settings) are not modified

v lines that start with a numeric digit (0-9) are not modified
v a block number is inserted at the start of all lines that begin with an alphabetic

character (“A-Z”)
v if a line begins with a "/" or "\" symbol followed by an alpha character (eg: “/X1.2”),

the symbol is considered a “block skip” character and a block number is inserted
immediately following the symbol (eg: “/N10X1.2”)

v a space is inserted following the block number if the line already contains any
spaces

Do not renumber programs that use block sequence numbers as arguments for jumps,
subroutine calls or macros.

Removing Block Numbers

To remove all block numbers from a program, choose “Block numbers” from the Tools
menu and select the “Remove” option.    

User Guide  Page 27

 



4.9.2 Formatting and Filtering

To reformat a program, choose “Reformat” from the Tools menu, and choose format
options by checking or unchecking the following check boxes:

Remove leading and trailing spaces from each line.Trim

Remove all “unprintable” characters.Filter

Convert lower case characters to upper case.Convert to
Upper Case

Standardize the format of numeric values. Comments are
excluded.

Format Numbers

Compress program blocks by removing spaces between
words (“N10 G95 S600” changes to “N10G95S600”).
Compressing program blocks may reduce the amount of
CNC memory required to store the program. Comments
are excluded.

Compress

Expand program blocks by inserting spaces between
words (“N10G95S600” changes to “N10 G95 S600”).
Expanding blocks makes the program easier to read.
Comments are excluded.

Expand

Format and filter options may be combined. If Expand and Compress options are both
selected, Compress is completed before Expand.

4.9.3 Block Skip

Choose "Block Skip" or "Block Unskip" from the Tools menu to insert or remove "Block
Skip" characters from the start of lines in your program. Many CNCs have a "Block Skip"
switch that, when turned on, causes the CNC to skip over blocks that start with a special
character, usually "/". The "Block Skip" command inserts the designated "block skip"
character at the start of each selected line, or at the start of the current line if no lines
are selected. The "Block Unskip" command removes the block skip characters from
selected lines or the current line.

To view or set the Block Skip character, choose "Preferences" from the Edit menu.

You can use the Block Skip command with another character ("!" for example) to mark
blocks of text as comments, then use the Dostek DNC "omit lines" feature to prevent the
comments from being transmitted to the CNC (Configuration guide, Section 4.3). 

4.10 Printing

To print the current document to the Windows default printer using the current printer
setup, click the Print icon in the tool bar. To print the current document to a selected
printer or with specific printer settings, choose “Print” from the File menu. To change the
page layout used for printing, choose “Page Setup” from the File menu. If partial pages
or blank pages are printed or the page footer is at the top of a page, set the printing
margins larger (the printer may have an unprintable area larger than the current margin
settings). For best results, use a True Type font. When using a Generic/Text Only printer
driver, always set the paper source to "Continuous - Page Break".
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5 Communication

The Dostek DNC Communication application (DDNC32) may be started in any of the
following ways:

v choose “Dostek DNC Communication” on the Windows Start menu
v choose “Transmit”, “Receive” or "Receive Replace" on the Dostek DNC File

Manager “File” menu
v choose “Transmit” or “Receive” on the Dostek DNC Editor “File” or “Program” menus
v choose a Dostek DNC File Manager QuickButton you create
v click a Windows desktop shortcut you create
v drag one or more files from another application and drop them on the desktop

shortcut you create

5.1 Communication Basics

The main forms used by the Dostek DNC Communication application are illustrated in
Figure 4. The Communication form provides a menu, banner panel, file preview window,
command buttons and status bar.

Banner Panel

The Banner panel displays the name of the current device configuration file, its associ-
ated icon, and the name of the current file. The communication parameters, device
description and full file specification are also visible as a "tool tip" when the mouse is
held over the icon, device name or file name, respectively. Clicking on the device name
or file name displays the Settings form or File Selection dialog, respectively.

File Preview

When Transmit mode is selected, the File Preview window lets you view the file before
starting the transfer, search for text, pick a starting point or select a block of text. After
the transfer is started, the File Preview window is automatically scrolled to indicated
progress of the transfer. 

When Receive mode is selected, the File Preview window displays received data. When
finished receiving, the received file can be viewed or searched.

5.1.1 Startup

When the Communication application is started, the following information is required
before starting to transfer data:

v communication mode
v name and location of the file(s) to transmit or receive
v device configuration

Some or all of the startup information may be specified on the command line or can be
determined automatically. When launched from the File Manager or Editor, the file and
communication mode are usually specified. If additional information is required, the
Settings form is displayed (Figure 4, lower).
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Figure 5 - Communication Features
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5.1.2 Multitasking

The multitasking ability of the 32-bit Microsoft Windows operating systems permits  
Dostek DNC applications to be used independently or to work together. There is no need
to stop, close or exit the Communication application, for example, in order to use the
File Manager or Editor.

Multiple DDNC32 instances can be used to simultaneously communicate with more than
one device, provided that each instance uses a different communication port. When a
new instance is started, DDNC32 reads the communication port setting from the device
configuration file. If a previous instance is already using the required port, DDNC32
displays a message indicating the status of the previous transfer and allows you to either
terminate the previous transfer or cancel the new transfer.

Each running instance of DDNC32 appears as a separate icon in the Windows task bar
labeled with the communication port number (COM1, etc.)

5.1.3 Sharing Ports

Multiple devices can share a communication port by using a manual switch box,
electronic switch box, or Dostek Model 208/216 CommSwitch. However, DDNC32 can
communicate with only one of the sharing devices at any time.

5.1.4 Active and Idle Modes

When communication is active, the DDNC32 menu and command buttons are disabled
(except "Stop" and "Start Now"), and the communication form is prevented (if possible)
from being moved, sized or closed. When communication is idle, all menus and controls
are enabled, the form can be sized or moved, and any of the following actions are
permitted:

v resume a stopped transfer by clicking the Continue button
v restart a transmit transfer from a different position in the file by clicking the "Start

from" command button or by choosing "Start from" from the File menu 
v scroll the preview window using the scroll bar or by pressing Page Up, Page Down,

Home or End
v search for text by choosing "Find" from the File menu or by pressing Ctrl+F
v edit or print the current file by choosing "Edit" or Print from the File menu
v reload the device configuration (and transmit file, if any) by choosing "Reload" from

the File menu
v view the communication settings, device description or full file specification by

holding the mouse cursor over the device icon, device name or file name the banner
panel

v choose a file, device configuration or communication option (Section 5.1.5).
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5.1.5 Changing File, Device or Options

To display the Settings form and change the communication mode or choose a different
device configuration, ensure the communication form is idle and choose one of the
following:

v click the device name on the banner panel
v click the Settings button
v choose "Settings" from the File menu

To display the File dialog to choose another file name or location, ensure the communi-
cation form is idle and choose one of the following:

v click the file name on the banner panel
v click the Browse button on the Settings form

The method for selecting a file depends on whether transmit or receive mode is
selected.

When Transmit is selected:

v to transmit a file located in the current folder, type the file name

v to transmit a file located in a different folder, type the full file specification including
drive, path and name

v to pick a file in any folder, click the Browse button

When Receive "AutoName" naming mode is selected:

v to receive files to a different folder, type the folder name
v to pick a folder, click the Browse button

When Receive "Manual" naming mode is selected:

v to receive a file to the current folder, type the file name

v to receive a file to a different folder, type the full file specification including the drive,
path and name

v to pick a file in any folder (to replace the file), click the Browse button

When the "Match device to folder" option is enabled (also referred to as "Automatic
Communication Protocol Selection"), DDNC32 restricts device selection to device
configuration file names that match the current folder. For example, if the current folder
is "Mill\Valve", DDNC32 restricts selection to any device name that starts with either
"Mill" or "Valve". If only one matching device configuration file is found, it is selected
automatically. When the "Match device to folder" option is disabled, or no matching files
are found, DDNC32 lets you choose from all available device configuration files.

If a different file location is selected, DDNC32 automatically displays the Settings form if
the previous device name no longer matches the new folder selection.

5.1.6 Reload

If you modify a loaded file or device configuration file after starting DDNC32, choose
"Reload" from the File menu to reload the new version of the files.
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5.2 Transmitting Files

When DDNC32 is ready to transmit a file, it waits for the designated trigger condition
before transmitting (5.2.1). Transfer can be stopped and restarted from the beginning or
from any position in the file (5.2.2). For drip-feeding applications, the program can be
automatically retransmitted when the end of the file is reached (5.2.3). If you are trans-
mitting to a Dostek Model 440 Behind-the-Tape Reader (BTR), refer to Section 5.2.9.

Multiple files can be organized in job files (5.2.8) and can be transmitted with or without
a pause between files (5.2.7). Large files can be managed in segments for faster starting
and viewing (5.2.6).

Transmit options are configured using the Dostek DNC Configuration program (refer to
the Configuration guide).

5.2.1 Transmit Trigger

Data transfer begins when a trigger condition occurs. The trigger condition is specified by
the device configuration file:

Data transfer starts when the designated trigger condition
occurs. DDNC32 can wait until a specified character is
received from the CNC (typically XON), or until the COM
port DSR input signal is turned on by the CNC. 

Automatic

Data transfer starts when the operator clicks the Start
button.

Manual

Data transfer starts immediately.None

DDNC32 displays a message in the status bar when waiting for a trigger condition to
occur. Click the "Start Now" button to  bypass an automatic trigger condition and start
transmitting immediately.

5.2.2 Transmit Start/Restart

To restart a transmit transfer, either click the "Restart" button to start from the beginning
of the file or click the "Start From" button and choose one of the following options:

Search for text such as a block number, comment or
G-code. 

Find Text

Transmit the selected text only.Selected Text

Start transmitting from a specific line number. The first
line in the file is line # 1. 

From Line #

Start transmitting from the start of the current line.From Current
Line

Start transmitting from the current cursor location.From Cursor

When starting from a specific line number, keep in mind that line numbers are not the
same as block sequence numbers (N10, N20, etc.). To start from a specific block
sequence number, use the Find Text option.
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When searching for text, the Find Text form remains on the screen so you can continue
searching for other occurrences of the text, or search for different text. Close the Find
Text form when finished searching. The Find Text option merely positions the cursor to
the matching text. To begin transmitting, you must click the "Start From" button again,
and choose "From Current Line".

5.2.3 Transmit Repeat Mode

When drip feeding, DDNC32 can automatically restart a program when the end of the
file is reached. To select a Transmit Repeat option, click Settings and choose one of the
following options:

The file is retransmitted immediately when the end of the
file is reached. 

Continuous

The file is repeated after waiting for the designated
Transmit Trigger condition to occur (Section 5.2.1).

Triggered

The file is not repeated.None

The default transmit repeat mode can be specified in each device configuration file.

5.2.4 Transmit Stop

A Transmit data transfer is terminated when the end of the file is reached and there are
no more files remaining to transmit, or when the operator clicks the Stop button.

5.2.5 Drip Feeding

DDNC32 can "drip feed" data to one or more CNCs operating in DNC mode. For reliable
drip feeding, the transmit flow control settings must be configured correctly. Use the
Restart feature (Section 5.2.2) to restart after a tool break, repeat a section of the
program, or resume an interrupted program. 

If you are running multiple parts with the same drip-fed program, set the Transmit
Repeat mode (Section 5.2.3) to automatically restart the program when the end of the
file is reached.

5.2.6 Transmitting Large Files

When a large file is transmitted, you can choose to view the file in "segments" for faster
loading and viewing. 

Use the Navigate menu to navigate a large file when viewing file segments. Choose "Go
to" (Ctrl-G) to load the segment corresponding to a specific offset into the file (either
percentage or number of bytes), or choose "Next segment" (Ctrl-N) or "Previous
segment" (Ctrl-P).
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5.2.7 Transmitting Multiple Files

Multiple files can be transmitted in any of the following ways:

v click the "Browse" button on the Settings form and select multiple files by holding the
Shift or Ctrl key down while clicking file names (all files must be picked from the
same folder)

v click the "Job" button on the Settings form and create or manage a file group
v with the File Manager, select multiple files and choose the Transmit command
v with the File Manager, transmit a job file (Section 5.2.8)

When multiple files are transmitted, click the "Job" button on the Settings form to use the
Job File Manager to add, remove or reorder file names, or restart transmit with a specific
file.

A related group of files with similar names can be selected using the File Manager
"Name Search" command (Section 3.2.4). To simplify automatic selection by file name,
ensure related files share the same name with a unique suffix or file extension (for
example, "O1234-1", "O1234-2", etc., or "O1234.1", "O1234.2").

A related group of files that contain a particular part number in a comment can be
selected using the File Manager "Search Contents" command ( Section 3.2.4).

If the "Pause between files" setting in the device configuration file is enabled, DDNC32
pauses after each file and waits for a transmit trigger condition to occur before sending
the next file.

5.2.8 Job Files

A Job file is a file containing a list of file names (Sections 3.5.4, 5.2.8). When a job file is
selected for transmitting, the files named in the job file are transmitted in the order they
are listed. Click the "Job" button on the Settings form to use the Job Manager to add,
remove or reorder file names, or restart transmit with a specific file.

If multiple files are selected and one or more job files are included, only the first job file
is transmitted.

5.2.9 Transmitting to a Dostek Model 440 BTR

Transmitting using the "BTR440" communication protocol used with the Dostek Model
440 Behind-the-Tape Reader (BTR) is slightly different than transmitting with other
protocols. 

Because the 440 BTR replaces the tape reader, you use the BTR the same way you
would use the tape reader. Since you would load a tape on the tape reader before
loading or running it, you must load (Transmit) a file into the 440 BTR before you load or
run the file on the CNC. If the file is too large to fit in the BTR's memory, DDNC32 will
incrementally send more data to the BTR as the CNC reads data from the BTR, until the
entire file is sent. You can load a file into the CNC's memory or you can "drip feed" a file
directly from the BTR. Operation of the 440 BTR and the Dostek DNC software is
exactly the same in either case.

When DDNC32 starts, it first initializes (resets and tests) the 440 BTR and displays a
yellow status panel until initialization is complete. Next it turns the status panel green to
indicate that you may now start a read or run operation on the CNC. As soon as the CNC
starts reading data from the BTR, the status panel turns into a progress display. 
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5.3 Receiving Files

Received data is stored in a file (or files) according to file naming option settings in the
system configuration and device configuration files (Section 5.3.1).

Received files replace original files without confirmation (Section 5.3.2). Files replaced
on a local hard drive may be protected by the Windows Recycle bin. For more informa-
tion about protecting files, refer to Section 2.4.1 in the Configuration Guide.

When Receive is terminated (Section 5.3.3), a report is displayed to indicate the size,
error status and file replacement status of each received file (Section 5.3.4).

5.3.1 Receive File Naming

DDNC32 provides a choice of three modes for naming of the files in which received data
is stored:

All CNC programs are stored in a single file named
according to either the name or part number of the first
CNC program received. Use this option to keep
subprograms in the same file with main programs.

AutoName: Single

Each CNC program is stored in a separate file named
according to either the CNC program number or a part
number stored as a comment in the first or second line of
the program.

AutoName: Individual

The operator must enter a file name or select an existing
file (to replace). If a name is not specified, “Untitled” is
used. All received data is stored in one file.

Manual

The default receive file naming mode is determined by the Dostek DNC system configu-
ration settings, but reverts to Manual mode if automatic naming is disabled by the
current device configuration file.

Use the Settings form to change the file name, location or naming mode (if permitted).

Configuration of Dostek DNC automatic file naming options is explained, with examples,
in Section 5 of the Configuration Guide.   

Manual File Naming

When manual naming mode is selected, you can specify a receive file using the Settings
form in one of three ways:

v type a file name in the Receive File text box
v click the Browse button, choose a folder and select an existing file
v click the Browse button, choose a folder and type a new file name
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Automatic File Naming

When automatic naming of received files (AutoName) is enabled, CNC programs are
stored in files named according to either the CNC program number or a part number
stored as a comment in the first or second line of the program. DDNC32 can extract all
or part of the name and add a prefix, suffix or file extension. For example, if the CNC
outputs the program name in the format “$12345678.MIN”, DDNC32 can automatically
store the program in a file named “12345678.TAP”. Or, if the first line of a program is
“O1234 (75X438-22-001 UPPER CONTROL BRACKET)”, DDNC32 can name the
received file according to the program number (O1234), the entire line, the text enclosed
within the parenthesis, or the portion of the text in parenthesis up to the first space
character.

Choose Manual naming mode to save data that does not contain a detectable program
name (machine parameter or tool offset data, for example). If DDNC32 is unable to
detect a program name (when automatic naming is enabled), received data is stored in a
file named "Untitled".

5.3.2 Replacing Existing Files

Existing files with the same name as a received file are replaced directly without display-
ing a confirmation message. If received files are stored on the computer's hard drive,
replaced files are moved to the Recycle Bin (if enabled, Section 3.7) and can usually be
recovered if necessary. Files received to a network drive are not protected by the
Recycle Bin.

5.3.3 Receive Terminate

When the CNC is finished sending data, click the DDNC32 "Stop" button to terminate the
receive operation on the computer. A report is displayed (next section) so you can verify
that all files are received and stored properly. If the computer is turned off (or the power
fails) before Stop is clicked, some received data may be discarded. 

Receive can also be terminated automatically when a specific character or phrase is
received. Refer to the Configuration Guide, Section 4.5.2, for more information.

User Guide  Page 37

 



5.3.4 Receive Report

When receive is terminated, DDNC32 displays a report listing the name of each
received file along with the following information:

v file size
v receive error status
v file replacement status 

The "Replaced" column is checked if a file with the same name was already present and
was replaced (Section 5.3.2).

The "Status" column indicates communication error codes, or "OK" if no errors were
detected. Communication errors are indicated by the following single letter codes:

Receive overflow error. May indicate the flow control is set
incorrectly, or may occur if the communication form is moved or
re-sized while communicating

V

UART overrun error. May indicate the computer is momentarily
too busy to process received data, possibly because another
process is disabling interrupt processing for an extended period.
Try the following:
vensure the communication port's receive FIFO is enabled and set

it to the maximum size
v reduce the baud rate
veliminate other processes to determine if one is affecting

performance

O

Parity error.
Framing error.
Break error.
Parity, Framing and Break errors are common when the baud rate,
data bits, stop bits or data format of the computer and CNC do not
match.

P
F
B
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6 MultiPort DNC

This section explains how to use the Dostek DNC MultiPort Edition DNC communication
server module (DMDNC32.EXE).  

Dostek MultiPort DNC provides remote access, unattended operation and client/server
features. Remote access lets operators upload and download files directly from their
CNC station. MultiPort Edition can be installed as a Windows service for unattended
operation, starting automatically when Windows starts and continuing to run while users
log on and off the computer.

6.1 Remote Request

Dostek MultiPort DNC provides a "Remote Request" feature to allow CNC operators to
upload and download files to and from the computer directly from their CNC workstation.
Commands are sent from the CNC to the computer by creating a small file containing a
command in a specific format. Normally, commands are enclosed in parenthesis and
consist of a single command letter followed by any optional command arguments such
as file name. For example, the command "(+T O1234)" requests MultiPort DNC to
transmit file O1234 to the CNC. The actual command format can be customized
separately for each CNC. In this manual, all commands are shown in the factory default
format.

When operating in Remote Request mode and waiting for a command from the CNC,
Dostek MultiPort DNC monitors the communication port and stores any received data
according to the program number found in the data received from the CNC. This means
that the Dostek DNC "Automatic naming of received files" feature (Configuration Guide,
Section 4.6) must be enabled and properly configured for each channel operating in
Remote Request mode. If a program number is not found, received data is stored in a
file named "Untitled-001". If the Untitled file already exists, the numeric suffix is
increased until an unused name is found. 
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MultiPort DNC evaluates each received file to determine if it is a command file accord-
ing to the "Command Files" setting on the DConfig (Dostek DNC Configuration applica-
tion) "Remote Request" tab. If the "Scan all small files for commands" option is checked
and the file is smaller than about 500 characters, MultiPort DNC searches the file for
commands. If the "Master Command Program" option is checked and a program match-
ing the specified master program number is received, the received file is assumed to be
a command file ("Command Files", Configuration Guide Section 6.2.4). Any file that is
not determined to be a command file is stored as a CNC program file (in the folder
specified by "Receive to" on the Device Properties "Receive" tab).

If data is received while MultiPort DNC is transmitting to the same CNC, the transmit
operation is canceled and the received data is processed and stored. Thus, the CNC
operator can store a program file at any time by simply using the CNC's "Punch" or
"Output" command.

Dostek MultiPort DNC provides the following remote request commands:

Request MultiPort DNC to send a list of recent
messages from the CNC's activity log record.     

+MMessage

Request MultiPort DNC to send a list of files or folders
matching a particular name or specification.    

+DDirectory

Request MultiPort DNC to store data from the CNC into
a specified file name on the computer. 

+RReceive

Request MultiPort DNC to send a specified file from the
computer to the CNC.

+TTransmit

DescriptionDefaultCommand

Command options, parameters and syntax rules are explained in Appendix A, "MultiPort
DNC Command Reference".

6.1.1 Creating Command Templates

Command template programs can be used on the CNC to simplify sending commands to
the computer. For example, program number 7990 can be reserved for a Transmit
command template. This way, the operating procedure for loading a file from the
computer will always be:

1. edit program 7990 to insert the name of the requested program
2. punch program 7990
3. press Read or Input button

The command template program will usually contain a single line, although comments
can be included to provide operator instructions. For example:

O7990 (DNC LOAD)
(+T,A123-456)
(DNC COMMAND TEMPLATE FOR FILE DOWNLOAD)
(1.TYPE THE NAME OF THE PROGRAM AFTER T,)
(2.PUNCH O7990 TO COMPUTER)
(3.WAIT 5 SECONDS)
(4.PRESS READ BUTTON)
%   
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If only the "Master Command Program" option is enabled (Section 6.1), the command
template program number must match the specified program number range. If the "Scan
all small files for commands" option is enabled, the template file must be less than 500
characters in size. Any file that does not match these criteria is stored as a CNC
program file.

Creating command templates may be difficult or limited on some CNCs. In this case,
however, command templates can be created on the computer and loaded into the CNC
using the standard communication module (Section 5, "Communication"). A backup copy
of the command templates can be stored on the computer in case they are accidentally
erased from the CNC memory.

Some CNCs do not permit the operator to enter the parenthesis characters "(" and ")"
into a program. If the CNC will display the parenthesis characters and allow the user to
edit the text enclosed within the parenthesis, a command file template can be created on
the computer and sent to the CNC where the operator may edit the command template.

Some older CNCs do not permit the use of parenthesis characters in a program at all. In
this case, the command format specification on the device configuration Remote
Request tab must be changed to a command format that is compatible with the CNC.
For example, some older CNCs will accept a line starting with "L" as a comment, so the
Transmit command could be configured as "L+T,filename" instead of
"(+T,filename)".

Using Comments

Comments may be included in template files to provide instructions for the operator, as
illustrated by the sample template on the previous page. 

When permitted by the CNC, a comment may also be included on the program number
line as shown in the sample template. This way, the template files will be identified on
the CNC program directory screen. For example:

O1234 (R4287 END PLATE)
O7990 (DNC LOAD)
O7993 (DNC STORE)
O7997 (DNC DIRECTORY)
O7998 (DNC MESSAGES)

Multiple-Line Commands

Dostek MultiPort DNC permits commands to be split into two or more lines. To split a
command into two or more lines, place a "+" character a the end of each line to be
continued. This feature makes it easier for CNC operators to enter a file name in a
command template program when a folder name or file prefix is used. For example:

O7990 (DNC LOAD)
(+T MILL/ORIGINAL/+)
(O1234)
%

Character Substitution

Some CNCs do not allow certain characters (for example, ":" or "\") to be used in
programs. Different characters may be substituted by changing the "Character Substitu-
tions" setting in the "Command Format" frame on the Remote Request tab in DConfig
(Configuration Guide, Section 6.2.3).
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6.1.2 Message Feedback File

Dostek MultiPort DNC sends a message file to the CNC when the Message command is
received or when an error occurs while processing a remote request command (for
example, the requested file is not found). The format of the message file is determined
by the "Message File Format" settings on the DConfig device "Remote Request" tab.

The "First line" setting can be configured so the message loads on the CNC as a particu-
lar program number ("O7999", for example). If the "First line" setting is blank, the
message file will load in the first available program number for most CNCs.

The message file should be deleted from the CNC memory as soon as it is read by the
operator. If the message file is not deleted, a CNC alarm will occur the next time a
message is received because a program with the same number is already present in the
CNC memory.

6.2 Storing Programs

When remote operation is enabled, MultiPort DNC normally stores each program
received from the CNC into a separate file named according to the parameters specified
in the "Automatic File Naming" frame on the DConfig (Dostek DNC Configuration appli-
cation) Device "Receive Options" tab. The "Default Receive File Naming Mode" setting
on the DConfig General "Communication Options" tab is disregarded. Refer to Configu-
ration Guide, Section 4.6, for more information about receive file naming.

CNC programs and data may also be stored under a specific file name (Section 6.2.1),
or multiple programs (such as a main program and it's subprograms) may be stored in a
single file named according to the first program received (Section 6.2.2). 

6.2.1 Store Each Program in a Separate File

To automatically save each CNC program in a separate file on the computer, simply
punch each program from the CNC. Each received program is stored in a separate file
named automatically according to the device configuration settings.

The CNC may allow you to punch out a range of programs (for example,
"O1000-O1999") or all programs (for example, "O-9999") with a single command. 

6.2.2 Store Multiple Programs in a Single File

Multiple CNC programs (such as a main program and one or more subprograms) can be
combined together and stored in a single file. MultiPort DNC can name the file automati-
cally according to the first program received, or manually according to a file name speci-
fied by the CNC operator. 

Storing multiple programs into a single file involves three steps:

1. Send a command from the CNC to the computer to start receiving.

2. Send the programs from the CNC to the computer.

3. Send a Master Command Program (Section 6.1) from the CNC to the
computer to stop receiving and reset to the remote request mode.

To store one or more programs into a single file with a specific file name, use the
Receive command and specify a file name. Send the programs from the CNC to the
computer in any order. For example:
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(+R A123-456)

After the data is sent, a "Master Command Program" must be sent from the CNC to the
computer to signal the end of data and reset the channel to the remote request mode.
The Master Command program can be empty, or can include another remote request
command.

To store one or more programs into a single file named automatically according to the
main program, use the Receive Single command. For example:

(+RS)

Send the main program from the CNC to the computer first, then send the remaining
programs in any order. After the last program is sent, a "Master Command Program"
must be sent from the CNC to the computer to signal the end of data and reset the
channel to remote request mode. 

The MultiPort DNC Receive Single command names the file according to the first
program received from the CNC. When the CNC punches out a range of program
numbers (for example, "O1-O6999"), it may not punch the programs in numerical order.
To ensure the proper file name is used, consider the following:

v punch the main program by itself first, then punch the subprograms using a range of
program names

v store the file name as a comment with each program number; the order the
programs are punched does not matter; for example:

O1000 (A123-456)
O1222 (A123-456)
etc.

v if the CNC does punch programs in numerical order, ensure the main program is the
lowest program number (O0001, for example)

v ensure the MultiPort DNC remote command files and feedback files are not included
in the program range; for example, use range O7900 to O7999 exclusively for
MultiPort DNC command and feedback files

6.2.3 Store Programs to a Specific File

Received data can be stored under a specified file name to override automatic file
naming or to store CNC data, such as machine parameters, that does not include a
program number.  To store data in a specific file, use the Receive command as
explained in the previous section. For example, to save CNC machine parameters in a
disk file:

1. Send a Receive command from the CNC to the computer to start
receiving. For example, to store parameters in a file named
"PARAMETERS 03-10-2000", send the command:

(+R,PARAMETERS 03-10-2000)

2. Execute the parameter punch command on the CNC (on some Fanuc
CNCs, for example, select PARAM and EDIT modes and press OUTPUT
or PUNCH).

3. Send a "Master Command Program" (Section 6.1) from the CNC to the
computer.

6.2.4 Confirm Receive

The CNC operator can confirm that MultiPort DNC properly received the sent data by
sending a Message command and reading the MultiPort DNC message file.
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6.3 Loading and Running Programs

Dostek MultiPort DNC permits CNC operators to load or run (drip feed) part programs by
sending remote request commands from the CNC to the computer. Transmit commands
are provided to:

v load or run a single program
v load multiple programs
v load or run a program from a specific folder
v load or run a program from the queue
v load or run a program starting at a specific block

Transmit command syntax is explained in Appendix A, Section A3.

6.3.1 Loading a Single Program

Loading a program from the computer to the CNC involves three steps:

1. Create/edit a command file on the CNC

2. Punch/send the command file from the CNC to the computer

3. Execute a memory load/read command on the CNC to load the program
from the computer to the CNC

For example, to load the file named "O1234", create the following command file on the
CNC and punch or send the program to the computer. 

O7990
(+T O1234)
%

After sending the command file, wait about 5 seconds (to allow the computer time to find
the requested file) and execute a read or load command on the CNC.

If MultiPort DNC does not find the requested file or an error occurs, a feedback message
file containing a suitable message is sent to the CNC in place of the requested file
(Section 6.1.2). 

A file extension may be specified (for example, "O1234.TAP"). If a file extension is not
specified, the default file extension is used when searching for the file. To override the
default file extension with a null file extension, include a period at the end of the file
name (for example, "O1234.").
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6.3.2 Loading From a Specific Location

MultiPort DNC searches for requested files in the root folder specified for each CNC.
Sub-folders are searched if this option is enabled. To instead load a file from a specific
folder, specify a path with the file name. For example:

(+T MILL\ACME\O1234)
Request the file O1234 in the specified folder which is found in the
root folder configured for this CNC. If the CNC root folder is, for
example, "C:\TAPES", the full file name is
"C:\TAPES\MILL\ACME\O1234".

(+T C:\TAPES\MILL\ACME\O1234) or (+T \\SERVER\ACME\O1234) 
Request a file using a full file specification. For security reasons, the
requested file location must be within the root folder configured for
the CNC. UNC file names are permitted.

6.3.3 Loading Multiple Programs

To load multiple programs:

1. Create/edit a command file on the CNC

2. Punch/send the command file from the CNC to the computer

3. Load/read each program from the computer (execute a separate load/read
command on the CNC to load each requested file)

6.3.4 Loading a Program from the Queue

To load the next or previous program from the queue, follow the same procedure used
for loading a single program, except use the Transmit Next or Transmit Previous
command in the command file.

For example, to load the next program from the queue:

O7990
(+TN)
%

To reload the previous program from the queue:

O7990
(+TP)
%
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6.3.5 Running (Drip Feeding) a Program

To run (drip feed) a program, follow the same procedure used to load a single program,
except set the CNC to tape mode and press the Cycle Start (or equivalent) button on the
CNC instead of executing a memory load/read command.

Starting at a Specific Block

To start running or drip feeding a program from a specific block, use the Search option
of the Transmit command. For example, to start running a program at the first block that
starts with "N1000", send the following command to the computer:

O7990
(+T O1234 N1000)
%

Repeating a Program (Tape Loop)

Use the Transmit Continuous or Transmit Repeat mode to repeatedly run the same
program. When the Transmit Repeat command is used, MultiPort DNC waits for a
trigger to occur after each copy of the program is sent. When the Transmit Continuous
command is used, MultiPort DNC starts sending each copy immediately after the previ-
ous copy is finished. When the Search option is combined with the Repeat or Continuous
option, the first copy of the program is sent starting where the search string is found, and
all subsequent copies are sent from the beginning of the file. For example, to continu-
ously transmit the file O1234 starting initially at the first block that starts with "N1000",
send the following command to the computer:

O7990
(+TC O1234 N1000)
%

6.4 Searching for a Program

Use the Directory command to obtain a list of all files on the computer or to search for a
specific file. The "*" wild card option may be used. For example, to obtain a list of all
files whose name starts with "O12", send the following command file to the computer:

O7990
(+D O12*)
%

When queue mode is enabled, the directory command limits the search to the files in the
queue.

Directory command syntax is explained in Appendix A, Section A5.
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Appendix A

MultiPort DNC Command Reference

Dostek MultiPort DNC remote commands are formatted as CNC program messages or
comments. By default, Dostek MultiPort DNC formats messages and commands using
the ISO standard parenthesis characters, "(" and ")". However, any character or string of
characters can be specified by the Command/Message Start and Command/Message
End settings on the Remote Request tab in the Dostek DNC Configuration application
(refer to Configuration Guide, Section 6.2).

Each command has a separate identifier. The default command identifiers are listed
below:

+T Transmit file from computer to CNC

+R Receive file from CNC to computer

+D Transmit file directory from computer to CNC

+M Transmit recent messages from computer to CNC

Any character or string of characters can be specified for each command in the
"Commands" frame on the Remote Request tab in DConfig. For example, the command
identifier for the Transmit command could be changed to "#SEND". The "+" symbol is
used at the beginning of each command identifier to ensure that comments are not
incorrectly interpreted as commands. In the following command file, for example, the
comment starting with "(TYPE" is not interpreted as a Transmit command.

O7990
(+T,A123-456)
(TYPE PROGRAM NAME ABOVE AND PUNCH TO COMPUTER)
%   

A1 Command Parameters and Options

Commands may include parameters and options. For example, the Transmit command
supports two optional parameters (filename and search string) and two optional
command options (continuous repeat or triggered repeat). Command options may
appear in any order before or after command parameters. Command parameters must
appear in a specific order with respect to each other. The Transmit command, for
example, requires the filename parameter to appear before the search string parameter.

Command parameters and options must be separated by a 'delimiter' character. The first
non-alphanumeric character in the command string is considered to be the delimiter
character. For example, the delimiter is the space character for (+T MYFILE) and (+T
MYFILE /C), and the comma character for (+T,MYFILE). The command (+TMYFILE) is
not acceptable because there is no delimiter between the command and the command
parameter.



Command options may be specified in either of two ways:

v a single-character command option may appear immediately following the command
identifier, such as (+TC filename) 

v otherwise, a command option must be preceded by a command "Option Switch
Character" symbol, such as
(+T filename /C) or (+T -C filename)

The Command Option Switch Character for each device is set on the Remote Request
tab in DConfig (Installation and Configuration Guide, Section ???).

A1.1 Examples of Command Syntax

Following are some examples of command syntax:

(+T O1234.TAP) Transmit file "O1234.TAP"

(+T O1234) Transmit file "O1234". When a file extension is not specified,
MultiPort DNC automatically appends the file extension specified by
Name Format, Extension configured on the Device "Receive
Options" tab. If this setting is blank, the file extension specified by
Receive File Naming settings on the Global "Communication
Options" tab. If both settings are blank, the file extension remains
blank.

(+T O1234.) Transmit file "O1234". Because the period is included, MultiPort DNC
does not automatically use a default file extension. 

(+T,A422 TOP) Transmit file "A422 TOP". Because the delimiter is a comma (first
non-alpha and non-numeric character), the file name can include
embedded spaces.

(+T O1234 N100) Transmit file "O1234" starting with first line starting with "N100".
Because the delimiter is a space, "N100" is interpreted as the second
command parameter.

(+TO1234.TAP) This command is not valid because there is no delimiter between the
command "(T" and the parameters.

(+TC,O1234) Transmit file "O1234", repeating continuously. (Delimiter is ",").

(+T O1234 -C) Transmit file "O1234", repeating continuously. (Command Option
Identifier is set to "-").

(+T1\O1234) Transmit file "O1234", repeating when triggered. (Delimiter is "\").

(+T-) or (+T -) Transmit the previous file in the transmit queue.

(+T O1234_B) Transmit file O1234_B.

(+TO1234_B) This command is not valid because there is no delimiter between the
command "(+T" and the parameters.

(+TO_1234B) This command is not valid. The character "_" is interpreted as the
delimiter, but "O" is not a valid option for the Transmit command.
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A2 Receive Commands

In Remote Request mode, Dostek MultiPort DNC operates in "AutoName Individual"
receive mode by default. In other words, data received from the CNC is stored automati-
cally according to the program numbers found in the received data. If a program number
is not found, received data is stored in a file named "Untitled-001".

The Receive command lets the CNC operator request MultiPort DNC to store received
data in a specific file or to store multiple programs in a single file.

(+R O1234.TAP) Receive Manual command. All received data is stored in the
specified file until the "Master Command" program is received from
the CNC.

(+RS) Receive AutoName Single command. MultiPort DNC stores received
data in a single file named according to the first program number
received. This command is used to store a main program and
subprograms in a single file. Receive is terminated when the "Master
Command" program is received. Any data received before the first
program number is stored in an Untitled file.
Alternate forms of this command are:
(+R2), (+R /S) or (+R /2)

(+R) Terminate current Receive Manual or Receive AutoName Single
command and reset receive mode to AutoName Individual. 

When operating in "AutoName Individual" mode, each file is closed when the receive
terminate condition occurs (character, string or timeout as specified in device configura-
tion settings). 

The "Master Command" option on the DConfig "Remote Request" tab must be enabled
for the Receive Manual and Receive AutoName Single commands to work.

Operating procedures for receive commands are explained further in Section ???,
"Receiving Programs".

Received files are stored in the folder specified by the "Receive to" option on the
"Receive" tab of the MultiPort DNC "Device Options" form.

If the received file name does not include a file extension, MultiPort DNC automatically
appends the default file extension specified on the DConfig device "Receive Options"
tab or on the DConfig global "Communication Options" tab.
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A3 Transmit Commands

Transmit commands permit the CNC operator to request MultiPort DNC to send specific
files from the computer to the CNC.

(+T file) Request MultiPort DNC to send the specified file from the computer
to the CNC.

(+T file search)Request MultiPort DNC to send the specified file from the computer
to the CNC, starting with the first line that starts with the 'search' text.
Use this command to start drip feeding at a specific line in the
program.

(+TR file) Request MultiPort DNC to send the specified file from the computer
to the CNC, repeating the file each time a Transmit Trigger condition
occurs. Use this command to repeat while drip feeding, but pause
after each time to wait for the operator to press the cycle start button.
The optional 'search' parameter may also be specified.
Alternate forms of this command are:
(+T1 file), (+T file /R) or (+T file /1)

(+TC file) Request MultiPort DNC to send the specified file from the computer
to the CNC, repeating the file continuously until another command is
received. Use this command to continuously repeat while drip
feeding. The optional 'search' parameter may also be specified.
Alternate forms of this command are:
(+T2 file), (+T file /C) or (+T file /2)

(+TP) Request MultiPort DNC to send the previous file in the queue. Use
this command to reload the last program. 
Alternate forms of this command are:
(+T3), (+T /P) or (+T /3)

(+TN) Request MultiPort DNC to send the next file in the queue. Use this
command to load the next file in the queue. 
Alternate forms of this command are:
(+T4), (+T /N) or (+T /4)

A full file name including drive, path and type (extension) may be specified. If the drive
and path are not specified, MultiPort DNC searches for the file in the "Root Folder"
specified on the "Transmit" tab on the MultiPort DNC "Device Properties" form. If a file
type is not specified, MultiPort DNC automatically appends the default file extension
specified on the DConfig device "Receive Options" tab or on the DConfig global
"Communication Options" tab.

The following combinations of command parameters and options are permitted:

(+TC file search)
Request MultiPort DNC to send the specified file from the computer
to the CNC, starting with the first line that starts with the 'search' text
and repeating the file continuously (repeating from the beginning of
the file).
Alternate forms of this command are:
(+T2 file search), (+T file search /C)

(+T /P /C) Request MultiPort DNC to send the previous (or next, /N) file in the
queue, repeating the file continuously. 
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A4 Message Commands

Message commands permit the CNC operator to request MultiPort DNC to send a list of
the most recent messages recorded in the device log file. This command can be used to
verify that a receive operation was successful, test that MultiPort DNC is started and
responding to commands, review recent activities or review recent error messages.

(+M nn) Request MultiPort DNC to send a list of the most recent nn messages
for this device. If the number parameter (nn) is omitted, all saved
messages are sent. MultiPort DNC saves only the most recent
messages, about 25 in total. 
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A5 Directory Commands

Directory commands permit the CNC operator to request MultiPort DNC to send a list of
the files or folders matching a file specification.

(+D {filespec}) Request MultiPort DNC to send a sorted list of all matching files,
including only the name. The file size and file date/time are not
included. The optional filespec parameter may include a specific file
or folder name or a partial file name with a wildcard character ("*"). If
the filespec parameter is omitted, a list of all files in the Transmit
Root folder is provided. For example, (+D O2*.TAP) provides a list
of all files starting with "O2" and ending with ".TAP". The filespec
parameter may contain a drive and folder. For example, (+D
C:\TAPES\MILL\) provides a list of all files in the "C:\TAPES\MILL"
folder, and "MILL\" provides a list of all files in the "MILL" folder
located in the Transmit Root folder.

(+DT {filespec})Request MultiPort DNC to send a sorted list of all matching files,
including only the name and file date/time. The file size is not
included. The optional 'filespec' parameter may be specified.
Alternate forms of this command are:
(+D2), (+D filespec /T), (+D filespec /2),
(+D /T filespec), etc.

(+DS {filespec})Request MultiPort DNC to send a sorted list of all matching files,
including only the name and file size. The file date/time is not
included. The optional 'filespec' parameter may be specified.
Alternate forms of this command are:
(+D3), (+D filespec /S), (+D filespec /3), 
(+D /S filespec), etc.

(+DA {filespec})Request MultiPort DNC to send a sorted list of all matching files,
including the name, file size and file date/time. The optional 'filespec'
parameter may be specified.
Alternate forms of this command are:
(+D4), (+D filespec /N), (+D filespec /1),
(+D /N filespec), etc.

(+DF {filespec})Request MultiPort DNC to send a sorted list of all matching folders
(not files), including the name only. Alternate forms of this command
are:
(+D5), (+D filespec /F), (+D filespec /5),
(+D /F filespec), etc.

If the transmit queue option is enabled, the Directory command limits the search to the
files currently contained in the queue. Use the (+D) or (+D*) command to request a list
of all files in the queue. The current file in the queue will be marked by an "*" character
in the queue directory listing .
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Appendix B

Advanced QuickButton and Utility
Functions

This Appendix explains how to use Dostek DNC File Manager QuickButtons and Utility
menu to launch and run external applications.

The Utility menu is intended for launching external applications from within Dostek DNC
File Manager.

To create a QuickButton that launches another application, choose "External command"
from the command list and type a command specification in the adjacent text box.

If the external command specification includes spaces, it must be enclosed within
quotes. Special tokens may be used to substitute the currently selected file or files.

Substitute the File Manager root folder.%R
Substitute the current File Manager folder (directory). %D

Substitute a list of all selected files. Each file name includes
the full path and extension and is enclosed within quotes If
more than one file is selected, each file name is separated by
a semicolon.

%S

If the substituted text includes one or more spaces, it is
enclosed in quotations.
Append X to omit the file extension:
    %NX  -  O1234

Append D to substitute the DOS (short 8.3) file name:
    %FD  -  C:\PROGRA~1\O1234.TAP

Substitute the name and extension (without a path) of the
currently selected file. 

%N

Substitute the full path, name and extension (type) of the
currently selected file (the most-recently selected file if more
than one file is selected (highlighted)).

%F

Examples of external commands:

notepad %F
open the current file using Notepad

C:\Office\MSACCESS.EXE
run Microsoft Access

"E:\My Documents\TOOLS.MDB"
open Tools database document

start command /c erase "%R\*.TMP" /s
run the DOS "ERASE" command to delete all files matching "*.TMP" from the
Dostek DNC File Manager root folder and all; quotes are required if root folder
name contains spaces
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